Page 1 of 2 12 LastLast
  1. #1

    I reciently picked up one of those Chinese 6040 routers you see on eBay. Worked right out of the box, very pleased! But didn't like the manual control of the spindle... Eventually, I found this gem:


    I got a cheap RS-232 to RS-485 converter (about 3 from ebay) and wired it up with an old cut up usb cable (connected the shield only at the converter end. Installed the plugin and it worked! I can set the spindle speed in Mach3 and get a readout of what the actual speed is. The instructions on website are excelent, so I won't bother re-writing them here.

    As I understand it, I can also add a custom readout to the Mach3 screen to show the current current being drawn by the spindle.

    One gotch to look out for: Make sure the the Huanyang VFD's interface board board has the transevier populated. U4 I think. Mine did, so I was in luck and didn't have to solder one on.

    Hope this helps someone out there.

    Last edited by JayPunchbuggy; 26-03-2013 at 10:16 AM.

  2. The Following User Says Thank You to JayPunchbuggy For This Useful Post:

  3. Thanks for posting this Jay, made it a sticky thread :).

    Anyone looking for the USB RS485 485 converter / adapter here is a link to the best price i could find: USB-to-RS485-485-Converter-Adapter-ch340T-chip-Support-32-64-XP-Win7-Vista

    I'v also attached the plugin along with the usb driver.

    Below is the plugin in action:

    Attached Files Attached Files

  4. #3
    Did you have any problems setting this up at all Jay?? Just tried it myself as I wanted to have spindle speed controlled by mach3, downloaded everything OK installed OK set up the plug in OK & got the message that it had been successfully configured but when I start mach3 things seem to start ok, machine moves, spindle starts & everything looks great but then I get an estop & it all stops.
    Thought it might be a problem with one part of the gcode but it does it in a different place everytime so no consistency other than it bringing up the estop.

  5. #4
    Just to let you know i have one of these working on linux....still trying to get thinks working in linuxcnc though :-(
    If the nagging gets really bad......Get a bigger shed:naughty:

  6. #5
    This is brilliant guys, never even knew you could do that, I've ordered my usb to rs485 from the link Lee posted, now I play the waiting game...

  7. #6
    I've obviously done something wrong, just can't seem to find out what lol.
    Other thing is that having set it all up I have closed mach3 down & re opened it a few times & each time I get the same wizard screen up asking me if I want to configure the plugin. If I accept I get the screen up for setting the com port & other bits. When I click ok I get a massage saying can't read value but if I click ok again I get the successfully installed message.

  8. #7
    Hmmm... I used an RS-232 to RS-485 converter, not a USB one. Wonder it this could make a difference? Will think about it.

    Are you able to enter a target rate into Mach3 and then hit F5 and get the spindle to start and reach that rate?
    Last edited by JayPunchbuggy; 16-04-2013 at 09:52 PM.

  9. #8
    I've read about people having problems with usb to serial converters because of the 2 different chip sets used the FTDI chipset is suppose to be the one to use & that is what I have on another computerused, it is also set up as a virtual serial port & has never given me any problems.
    Set this one up just the same way.

    After starting mach3 & getting a couple of error messages I get the successfully installed message & can reset the stop button that flashes when mach3 opens.
    Now if I just try to start the spindle there is a click & the estop starts flashing, tried reducing the speed but same thing just keeps happening.
    If I load some gcode & start mach3 then the spindle starts, the machine moves to the correct starting position & then starts to cut the job, it then seems to just stop for no reason, the estop will be flashing & I need to reset it again. Doesn't happen on the same line of code everytime but it is always an estop condition, can't see anything on the diagnostic screen but then again I wouldn't know what I was looking for anyway lol.

  10. #9

    Because it works a little bit, it sounds like a noise issue on the signal lines. Usually RS-485 is quite immune to noise.

    I used one of these from eBay:
    RS-232 to RS-485 Adapter Interface Converter | eBay

    I wired it with a shielded twisted pair cable, connecting the shield to earth ONLY at the PC's side.

    Can you supply details on how your inverter is wired and connected to the computer?


  11. #10
    It's connected using one of these that I actually bought for something else a while ago Jay.

    USB to RS485 Adapter Dongle Converter FTDI Chipset - EPOS, CCTV, Industrial | eBay

    Cable was a length of 0.5 CY cable that I had left over from wiring up the drivers. Shield wasn't run to ground at either end so will try running it to ground at computer end when I go up the unit today.

    I just used bit's that I already had but if they are not suitable then I will happily go out & buy the right bits if it means it will work. The motherboard has a serial connection on it already so wouldn't be a problem to use that although it does drive my plotter at the moment.

Page 1 of 2 12 LastLast

Similar Threads

  1. Mach3 Controlling Huanyang HY02D223B 2.2KW VFD
    By Mad Professor in forum Routers, Spindles & Controllers
    Replies: 34
    Last Post: 3 Weeks Ago, 09:21 AM
  2. Mach3 ports and pin setup to match my control box
    By Sparky in forum Artsoft Mach
    Replies: 17
    Last Post: 13-11-2014, 03:00 PM
  3. Replies: 12
    Last Post: 29-11-2010, 03:24 AM
  4. HID interface for remote control of Mach3
    By Smiler in forum Electronic Project Building
    Replies: 0
    Last Post: 10-05-2009, 11:59 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts