Page 2 of 2 FirstFirst 12
  1. #11
    Had another look at the machine today, no warnings on start up now but still bringing up estop. I'm wondering if it could be some sort of interference as the indicated spindle speed in mach3 was all over the place but the spindle seemed to be running fairly consistently when running before stopping when the estop came up.
    If it is interference then what can I do to fix the problem??

    Spindle will now start some of the time & runs for a period of time, never more than a minute or 2 though & most of the time nowhere near that long.
    Last edited by martin54; 18-04-2013 at 12:03 AM.

  2. #12
    John S's Avatar
    Lives in Nottingham, England, United Kingdom. Last Activity: 3 Hours Ago Has been a member for 9-10 years. Has a total post count of 1,937. Received thanks 124 times, giving thanks to others 44 times. Referred 1 members to the community.
    Go Config > General config and in top right change the top debounce setting to 2000 then try that if it still barfs out go 4000
    Don't worry about the high numbers they are in microseconds.
    It makes it take longer before it polls for a fault.
    John S -

  3. #13
    Quote Originally Posted by martin54 View Post
    If it is interference then what can I do to fix the problem??
    You could try:
    1) make sure the shield of the RS485 cable is actually earthed by the checking the continuity of it to the PCs chassis
    2) Ensure that the RS485 cable is not run near sources of interference, like the spindle cable. Especially avoid running the RS485 cable parallel to any other of these cables.
    3) try a lower baud rate
    4) reposition the USB to RS485 converter

    Hope this helps! To suggest more, a photo or more detailed description of your wiring would be useful.


  4. #14
    Just a quick update on this as I have gone over everything again & also tried the converter that Jay had bought & uses.
    Had all sorts of different messages depending if it was via the serial to 485 connection or the usb connection.
    it will run run on the plugin on this thread but stops at some stage. On the original mach3 plug in that is available via the mach forum it starts the spindle, cuts the job, returns to zero but does not stop the spindle.
    Actually got some work to do that I get paid for just now so this is going to have to wait. Just as well I haven't been asked for any work that I would need to use the router for lol.

  5. #15
    Hi Guys,

    The first post about this plugin intrigued me so I ordered the usb to rs-485 converter and waited 2 weeks for it to come... I've finally got around to testing the setup today and I'm experiencing a similar problem to Martin. I've installed the usb to rs-485 converter and that seems to be ok. The plugin config screen is working and states that communication with the vfd has been established and pulls the max spindle speed and frequency to display them in the splash screen, so I can be sure that a connection has been made. I then try and fire the spindle up and I get a click from the vfd then mach3 is put into emergency stop situation. I've tried running from an M03 command via the MDI screen and the same happens. I've not tested with any gcode because I don't have any that I know works (not finished my machine build yet).

    I have tried with the spindle wired to the vfd and without. I've tried with an old serial cable with the shield grounded to my pc case. I'll maybe try and find a bit of twisted pair cable like Jay said, see if thats any different. As for the parameters, I've done exactly as the ones provided by the guy who compiled the plugin. Oh, and I've also tried with the baud rate reduced to 4800...

    Any other pointers would be helpful as I'm starting to wonder how reliable this method is going to be if its that sensitive to noise...

  6. #16
    Im not sure why its not working, sorry. However, The comments from the author might help.

    I just read them over again and remembered this setting that needed to be changed:

    "In Mach3 under Ports & Pins -> Spindle Setup ensure Disable Spindle Relays is unchecked under « Relay Control »Restart Mach3."

    If that doesn't help, the author of the plug in might be able to assist. Once it works, it really is great. Good luck!


  7. #17
    Hi Jay,

    Thanks for your fast reply! I've actually had a bit of a breakthrough... I think a combination of things were holding me back, but the noticeable one was to do with the monitoring section of the plugin configuration screen. The author of the page you provided the link to suggested that you could monitor a certain status from the vfd, have it displayed in a dro and set and estop threshold of a given unit. Following his advice I set a value for the estop threshold for one of the drop down options and forgot about it, it wasn't until I checked every single option that I found my mistake.

    The vfd now tries to run without the spindle connected. However, when I did connect the spindle the vfd throws a fault of open connection and forces an estop condition, which is actually damn clever :) I think perhaps a connection has come loose on the crappy chinese spindle plug / socket. More investigation is required, but I'm chuffed that the plugin is working enough for me to get this far. Hopefully it'll play ball when I put it through more testing soon

    Thanks for your help!

  8. #18
    Had another look at the weekend & still have a problem with the plugin tripping mach3 as soon as I try to start the spindle.
    The other plugin that is on the mach3 forum is a bit strange as well. If I start mach3 from scratch & press the spindle start there is a click & the button flashes yellow but the spindle doesn't start. If I load some gcode & run it the spindle starts, runs & stops as it should. If I then try pressing the spindle start button again the spindle starts & I can also change the speed, pressing the button again stops the spindle as it should, can do that all day long until I shut mach3 down. When I start it up again we are back to not being able to start the spindle until I have run some code.
    Not really a problem as it seems to work ok when cutting anything but just seems a bit strange.

  9. #19
    Hi Martin,

    Please forgive my ignorance, but have you set a target spindle speed in the dro before pressing the spindle start button? I was playing around with it for a good hour before I realised I hadn't set a speed, lol! That and what really made a difference was to reset the vfd to factory settings then enter all your parameters fresh, I think there is a certain order it likes it to be done in, I found some instructions that said that and it worked for me anyway. I was ready to throw the damn thing out of the window before I managed to get it going, then its the best thing ever :) Just in case you are experiencing any problems with interference, I used an old serial cable that was shielded, just used 2 cores and grounded the shield to my pc case. Worked very well for testing purposes. My machine isn't to a stage where I can tests its reliability for cutting yet though.

    I wish you the best of luck with getting it fully working.

  10. #20
    Sure it must be down to something I have done or haven't done lol but at the moment it's finding the time to sit down & work through problems. Machine works fine with the other plugin for cutting so there is no immediate rush. Think I will take your advice at some point though & start from scratch again, will reset the VFD to factory settings so I know where I am going & re enter all the values I need to change. Don't think it's an interference problem as the VFD must be communicating with the other plugin. Did originally use a bit of cy cable to connect but replaced that with a bit of shielded twisted pair after reading Jays comments.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Mach3 Controlling Huanyang HY02D223B 2.2KW VFD
    By Mad Professor in forum Routers, Spindles & Controllers
    Replies: 34
    Last Post: 3 Weeks Ago, 09:21 AM
  2. Mach3 ports and pin setup to match my control box
    By Sparky in forum Artsoft Mach
    Replies: 17
    Last Post: 13-11-2014, 03:00 PM
  3. Replies: 12
    Last Post: 29-11-2010, 03:24 AM
  4. HID interface for remote control of Mach3
    By Smiler in forum Electronic Project Building
    Replies: 0
    Last Post: 10-05-2009, 11:59 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts