Thread: BK12 end float?

Page 1 of 2 12 LastLast
  1. #1
    I've just fitted the Y axis ballscrew (from Chai) to my Warco WM16 mill and have noticed that there is 0.2mm of end float in the BK12 bearing block. I've tried tightening the locking nut as tight as I can do it with a 19mm spanner and I'm still getting 0.2mm float through the bearing. The bearing block is solid to the machine but the shaft is floating...I assume it's actually the bearings that are moving as the shaft is locked to them via the collars. There is plenty of thread on the ballscrew, so the locknut hasn't bottomed out. Is this normal???

    Any suggestions?

  2. #2
    Turns out that the bearings are moving in the blocks. I'll have to try our local bearing supplier tomorrow and see if they have some of these: Shim/Support Washer 20mm x 28mm x 0.3mm DIN 988. If not, I'll have to get the blocks skimmed to reduce the depth of the bore.

    I'm really pleased with the ballscrews and machining from Chai but these bearing blocks are shyte. Have I got some from a bad batch or is this "normal"? I guess this clarifies why John S told me he doesn't use the BK or BF bearing blocks!

    While on the subject, which way round should the 7001 AC bearings go in the blocks?

  3. #3
    Have I got some from a bad batch or is this "normal"?
    I'm not sure or it is normal, I bought from the same seller as you BK12 and screw and I have the same story like yours,
    I can feel quite big play in the block

  4. The Following User Says Thank You to Gytis For This Useful Post:


  5. Use some Loctite bearing retainer e.g. 638 or 641

    http://www.loctite.co.uk/retaining-4479.htm

  6. The Following User Says Thank You to irving2008 For This Useful Post:


  7. #5
    I've used loads of them and it can be hit and miss. Mostly they are Ok thou and the ones that's are suspect usually only need stripping and reassembling. I always strip and re-grease anyway so not a problem. Occasional I'll have to make a shim and at worst throw one in the lathe and skim bit off.
    The most common thing I find is the spacer isn't long enough so the Nut or screw catches the seals, again I just whip up one on lathe.

    Really for the money you can't complain and I think you have been a bit unlucky if they are all like it.? To make your own would cost more in materials then you have the time factor. Better for me if at worst 20-30mins stripping and fettling than half-full day making my own and costing more.

    Wouldn't Loctite that's a bodge IMO and not good enough for CNC work, best just doing it right and slip in a shim or skim bit off.!!

  8. The Following User Says Thank You to JAZZCNC For This Useful Post:


  9. #6
    Hmmm, the plot thickens. Made some shims for the outer races and still have end float. With the bearings on the ballscrew, not in the housing and the lock nut tightened fully, the outer races have around 0.3mm of play in them...so no matter how solidly fixed the inner and outer races are, the play is in the bearings themselves. Am I missing something here, or is it the "china" bearings that are crap?
    Last edited by birchy; 18-07-2013 at 09:06 PM.

  10. Quote Originally Posted by birchy View Post
    Hmmm, the plot thickens. Made some shims for the outer races and still have end float. With the bearings on the ballscrew, not in the housing and the lock nut tightened fully, the outer races have around 0.3mm of play in them...so no matter how solidly fixed the inner and outer races are, the play is in the bearings themselves. Am I missing something here, or is it the "china" bearings that are crap?
    Are you sure you have the bearings back-to-back? If not, you won't be able to preload them.

    Name:  044_0210_tcm_12-3904.jpg
Views: 579
Size:  7.4 KB

  11. #8
    Quote Originally Posted by birchy View Post
    I guess this clarifies why John S told me he doesn't use the BK or BF bearing blocks!
    I don't use them either - so far I've not seen one that didn't need a bit of TLC to remove the endfloat or other problems. I much prefer to spend a bit of time making my own so I know it's definitely accurate.

    Quote Originally Posted by birchy View Post
    Hmmm, the plot thickens. Made some shims for the outer races and still have end float. With the bearings on the ballscrew, not in the housing and the lock nut tightened fully, the outer races have around 0.3mm of play in them...so no matter how solidly fixed the inner and outer races are, the play is in the bearings themselves. Am I missing something here, or is it the "china" bearings that are crap?
    Are you sure the bearings are in the right way round? Are you sure the spacer Jazz mentioned is long enough? The bearings rings shouldn't be a tight fit. Either way if you look carefully you should be able to see the part that's at fault... can't really give a more precise answer than that.

    I wouldn't use Loctite as how can you properly preload the bearings if an adhesive is holding them?
    Old router build log here. New router build log here. Lathe build log here.
    Electric motorbike project here.

  12. #9
    I'll Bet 50p you have them in wrong way round.!! . . . . Possibly crushed spacer with over tightening.? (which you shouldn't have to do.!)
    Never had a spacer short enough to cause this, usually just lets nut or screw catch seals if short.

  13. #10
    The original bearings were both facing the same way which seemed wrong, so I turned one over. Actually I tried them both ways - back to back and front to front but get the same amount of float in either configuration. The spacer rings are OK and neither the nut or ballscrew is touching the seals. Chai has suggested I need to offset the bearing and/or ballscrew by 15 degrees. But that can't be right because the ballscrew would have to be a mile off centre to get that angle? However, based on that information I assumed that the bearings should NOT be perfectly square to the shaft, so shimmed the bottom only of the outer race with a 1/4 section of a 0.3mm shim washer and it seems to have done the trick. But it also feels like a bodge?!

    I've never used AC bearings before but assume that the "back" is the side which is stamped with the bearing number (7001)? If so, that's how they are currently configured. Without the offset shim they gave me around 0.25mm of end float. The other way round was no better.

Page 1 of 2 12 LastLast

Similar Threads

  1. WANTED: BK12 Bearing Block Wanted - 1 off
    By EddyCurrent in forum Items Wanted
    Replies: 7
    Last Post: 11-03-2017, 08:52 PM
  2. BK12 Hole Spacing Dimensions On Top
    By Hobgoblin in forum Lead Screws, Nuts & Supports
    Replies: 2
    Last Post: 21-09-2012, 10:31 PM
  3. BK12 & BF12 bearings
    By mlmSolutions in forum Lead Screws, Nuts & Supports
    Replies: 0
    Last Post: 04-01-2011, 11:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •