Page 1 of 2 12 LastLast
  1. #1
    Hi All,

    Title covers it all really, I have been testing my AM882 / ZPA5 setup and I have a peculiar problem that I have narrowed down but not resolved.

    I can control the motor with the Pro tune software and the motor moves smoothly. However, once the settings have been written to the driver and I try to run them from the ZPA board the motor jumps, jerks and stutters. It moves, in the correct direction but just like there is interference messing up the signal.

    So I have put some ferrite beads on the wires, tested it in the case and out of the case even tried another ZPA5 board from my other machine and it still behaves erratically when the BOB is in control.

    I wanted to call Zapp today as I am sure I am doing something obviously wrong but its a poxy bank holiday. So as I am super impatient, I thought I would try here in the hope that someone recognises my problem.


  2. #2
    Email me how you have wired it up.
    I should be able to get back to you today?

    Are you powering the zp5A from an external 5V power supply or the USB?
    If USB, my suggestion is dont.
    ALso take a vid of you jogging an axis so i can see the problem.

  3. #3
    legend - im on it.

  4. #4
    ok, email on its way.

    I think that anyone browsing this thread should be suitably impressed that you get a response on a bank holiday - a testament to your operation. It is greatly appreciated.


  5. #5
    Might sound bit obvious but you've not just tuned motor wrong in the control software are you.?

    Like Gary says without seeing wiring or what exactly it's doing it's hard to say anymore.

  6. #6
    Click image for larger version. 

Name:	Untitled-1.jpg 
Views:	171 
Size:	74.7 KB 
ID:	9777

    Motor tuning is ok as I am moving the stepper perfectly with the Pro-tune software. It is only when the control board takes over does it go wrong.

  7. #7
    Click image for larger version. 

Name:	ERROR.jpg 
Views:	124 
Size:	67.5 KB 
ID:	9778

    It says in the manual that erratic movement can be caused by weak signal or interference. How can I check for this?
    Last edited by badgerman; 26-08-2013 at 02:40 PM.

  8. #8
    Quote Originally Posted by badgerman View Post
    Click image for larger version. 

Name:	ERROR.jpg 
Views:	124 
Size:	67.5 KB 
ID:	9778

    It says in the manual that erratic movement can be caused by weak signal or interference. How can I check for this?
    You'll need an oscilloscope to do it properly but chances are you have just got something wrong with wires or settings.
    Your not trying to run this with a Laptop are you.?
    Where did you get the PP cable.? . . It must be a straight thru cable not an old printer or serial cable.

    Regards the motor tuning then that's nothing to do with Drive settings it's the control software sending out pulse's and if you motor tuning is set to high you could be getting stalling motors.?

    This will most likely turn out to be something simple like dodgy wire or wrong settings. Would be very unlikely you'll have electrical noise issues. The drives clearly work fine has do motors so they are ok and wired correct.

    It could be PC related like low voltage parallel port, unfortunately don't know anything about your BOB so unsure if it pulls signals high or not.?

    Sorry can't be more help than this.!!

    EDIT: Oh if your using Mach3 then try the PP driver test to check your PP port.
    If still having trouble and can't see any thing else wrong with wires, drives etc then sometimes a reinstall can help. It's not unknown for Mach's XML file to get corrupted and cause daft issues like this.!!
    Last edited by JAZZCNC; 26-08-2013 at 05:49 PM.

  9. #9
    Thanks Jazz - I will have a look.

  10. #10
    SO I messaged Gary and we talked over the issues, I noted that there was a brake on the stepper with 24v supply that might cause issue - she he said get rid of it and try again.

    Removed the brake, ran the standard ZPA profile for mach and the stepper motor jittered so violently that it nearly jumped off the desk!! Not the 24v supply I am guessing. . . . .

    I'm totally confused now so heres the rundown of trials to date -

    It has worked with the pro tune and with the direct parallel connection ( I wired up a parallel to stepper driver cable and it worked a treat) so there can't be any issue from the stepper-drivers to the steppers, or in fact the computer outputting signals.

    It has not worked in and out of the case, I initially tried it out of the case and thought the problem was as a result of it not being grounded properly. It did exactly the same when I put it in the case - so it can't be something isolated to its assembly and orientation in the case.

    . . . . . So, I am going to put the Zpa unit in my other machine to see if somehow I have lunched it. I bloody hope I haven't because it was doing the same thing with both the ZPA boards I have - so I would have knackered both!!

    Whatever is going on is happening on the ZPA board. I will wire up the board to my other machine tonight (GEKKO 203V's - worked a treat with them) but if it doesn't work I am seriously considering getting another board to try. Annoying though - 20 for the ZPA is a good price for a punt, but any more serious board will require more dollar. ... . . . and it still might not work!!!

    Anyone got any suggestions for a cheap driver board that will do the job?


Page 1 of 2 12 LastLast

Similar Threads

  1. I NeeD HeLp PLease AM882 a good choise
    By jpsicilia in forum Motor Drivers & Controllers
    Replies: 34
    Last Post: 16-08-2014, 09:27 PM
  2. Leadshine website and AM882
    By EddyCurrent in forum General Electronics
    Replies: 7
    Last Post: 01-10-2013, 07:18 PM
  3. Replies: 9
    Last Post: 03-04-2011, 12:52 AM
  4. How Rotary Broaching Works
    By steve3d in forum Tool & Tooling Technology
    Replies: 0
    Last Post: 18-01-2011, 02:17 AM
  5. My CNC WORKS...
    By in forum Metalwork Project Showcase
    Replies: 0
    Last Post: 30-09-2009, 05:04 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts