Page 1 of 2 12 LastLast
  1. #1
    Hi all.

    Im having problems with the big machine down the farm.

    Last time I was down there, I got it all working lovely. Since then, the computer it was all running off broke, and as such Ive had to start from scratch.

    This was a pain in the arse to get working first time round, but dont remember it to be such a pain.

    Im using a Dell Optiplex GX270, p4 tower. Running Windows Vista

    The breakout board is a UIM2901-5A MACH3 BREAKOUT BOARD WITH SPINDLE SPEED CONTROL from zapp
    manual link

    the stepper drivers are leadshine m860s, manual‎

    the wiring, is basic.
    Y AXIS STP >> PUL +
    Y AXIS DIR >> DIR +
    then DIR- and STP- wired back to the common on the same power supply the bob is wired too.

    Click image for larger version. 

Name:	wire.jpg 
Views:	819 
Size:	64.7 KB 
ID:	11319

    Im only trying to get one axis working for now, Y

    and mach is set up as the manual suggests

    Click image for larger version. 

Name:	manual.jpg 
Views:	1804 
Size:	38.1 KB 
ID:	11320
    Click image for larger version. 

Name:	ports.jpg 
Views:	376 
Size:	43.5 KB 
ID:	11321
    Click image for larger version. 

Name:	tuning.jpg 
Views:	214 
Size:	43.6 KB 
ID:	11322

    If, I put the voltmeter across the end of the parallel port (pin 4+ , pin 24-) I read 3.3v when 'jogging' the Y axis in one direction, and 0v when jogging in the other.

    likewise, if I put my voltmeter across DIR+ and DIR- on the driver (ie after the BOB) I get 5v one direction, 0v in the other

    Ive repeated the above example using an LED. (led ON one direction, off in the other)

    ive repeated the above 'test' using the pulse pins as well, it all appears to be working (ie until you jog, it reads 0v, you jog it goes high)

    Problem is, I obviously cant prove the Pulse in the same way. However I can 'hot potato' the PUL+ on the driver with 5v from the common supply and watch the stepper motor move.

    the wiring has not changed since it was fully working before.. the only variable is the Computer, the mach install and I suppose the fact the BOB has been kept in a cold barn with the machine.

    Ive literally spent all day, tried two different peace's of different computer hardware. changed the parallel cable. cant think of anything else to change? or test exercises.

    any thoughts... no matter how insignificant will be greatly appreciated.

    ps in other news... got myself a donkey saw!!!
    Click image for larger version. 

Name:	saw.jpg 
Views:	214 
Size:	161.6 KB 
ID:	11323

  2. #2
    Matt give me a ring asap I've lost your number.

  3. The Following User Says Thank You to JAZZCNC For This Useful Post:

  4. #3
    i2i's Avatar
    Lives in Cardiff, United Kingdom. Last Activity: 2 Days Ago Has been a member for 7-8 years. Has a total post count of 692. Received thanks 29 times, giving thanks to others 0 times.
    try a hairdryer on the boards.

  5. The Following User Says Thank You to i2i For This Useful Post:

  6. #4
    Don't read this, the last thing I want to do is piss you off, I'm only saying this for the benefit of others.
    "Configuration Management", is key once you get the machine working, this is a record of the following;

    All components including version No. of boards etc.
    Include computer components here also.
    Mechanical Drawings
    Electrical Schematics
    Photos of everything

    Version No.

    All settings of DIP switches on boards
    All software settings

    The idea is that if the machine ended up as a molten lump you would have all the information to recreate it.

  7. The Following User Says Thank You to EddyCurrent For This Useful Post:

  8. #5
    Quote Originally Posted by kingcreaky View Post
    However I can 'hot potato' the PUL+ on the driver with 5v from the common supply and watch the stepper motor move.
    It's possible that the hot potato damaged the driver input, although I can't tell for sure as the resolution of the picture of your breakout board on Zapp's site is not sufficient to identify the output driver ICs. If you're still able to measure a change from 0V to 5V on the outputs, whilst connected to the driver inputs (or an LED), then it's fine. In future, I suggest putting the potato in series with your 5V supply to the input, as it will limit the current, although you will need to be careful about the size of potato you select.

    Quote Originally Posted by kingcreaky View Post
    ive repeated the above 'test' using the pulse pins as well, it all appears to be working (ie until you jog, it reads 0v, you jog it goes high)
    When jogging, if the pulse signal is correct then it shouldn't go to 5V. It's a square wave, with 5us high time and at low speeds the low time is much greater. However you can still get meaningful readings with a standard meter. The meter should read anything from 0 to 0.87V (rms), depending on the feedrate. You could try running at the rapid speed you set (3m/min) and you should get 0.87V across the pulse input and 0.57V across the parallel port pins, assuming the meter is true rms which most are nowadays.

    You can also try setting the pulse output to be direction, to check if it's switching.
    Last edited by Jonathan; 19-01-2014 at 09:56 PM.
    Old router build log here. New router build log here. Lathe build log here.
    Electric motorbike project here.

  9. The Following User Says Thank You to Jonathan For This Useful Post:

  10. #6
    thankyou all for your input.

    Jonathon: probing the end of the parallel cable with my voltmeter gives almost exactly the figures you have quoted. I also note (little more primative) if I poke an LED with resistor into the pulse pin, the led comes on while the arrow(jog) key is down (probably pulsing but too quick for my eyes) then goes off when you release the key. The direction pin likewise behaves as expected (LED on in one direction, off in the other)
    However, if I repeat the above excercise at the output from the breakout board, the direction pin behaves the same. However the pulse pin just stays on regardless of if they key is down.

    Ive tried (I know this isnt clever) wiring direct from the parrelel cable to the driver. but no action. (I assume the current is too low at the end of the parrelel cable?)

    However, I wrote a simple program for the arduino to generate a pulse... wired that into the driver and the stepper turns as you would expect.

    I spent last night playing round with the Charge Pump, and 'enabled' option on the bob. Still no joy.

    Im now thinking, Id better try another break-out-board... but am open to advice on what to use. I have had a lot of success with the cheap BOB's that come from china 'free' with the DQ542MA drivers. However im not likely to get one of those on next day delivery so im scratching around at options.

    Ive just ordered a 'available' ZP5A-INT' off zap, however got a follow up email saying its out of stock. So, Im after options that are going to facilitate next day delivery.... anyone?

  11. #7
    Have you just been trying to run one of the axes or several? It's possible that one or more, but not all, of the outputs on the breakout board are damaged. Do the inputs still work?
    There are three ICs near the parallel port connector on your breakout board. Can you read the numbers to identify them? If so we can look at the datasheet and probe the board to see how far the signal is getting.

    There's not a lot wrong with wiring the parallel port directly to the stepper drivers, as they're opto-isolated. So long as you wire it up correctly - i.e. outputs to the step+/dir+ inputs and step-/dir- to pin 25. The thing that's probably stopping that method working is the parallel port is only 3.3V, yet the drivers require 5V.

    Unless you need particular special features I'd just get a breakout board you're familiar with.
    Old router build log here. New router build log here. Lathe build log here.
    Electric motorbike project here.

  12. #8
    Same bloody computer. Same model :-) . I kept it in my room for a couple of months, after i changed with newer. So basically all should have worked perfectly once powered.

    Before 2 days came my Galil board. So i wanted to test it. Nightmare! Mach3 not working, then windows stopped working, then graphic card stopped working, bought "new" card from boot sale for 5 euro, cleaned everything inside with contact cleaner, dried it with a hair drier, kicked it 2 times and now works perfectly. As my friend used to say-never power off the computer. Its cheaper and less troublesome.

  13. #9
    Matt SS and a BOB will be in the post tomorrow on next day del I missed Post office tonight. Try SS then return but you can keep the BOB.

  14. #10
    Hi, I sent you an email with the offer of some diagnostic equipment, but presume you didn't get it. I only live in Notts up the A46 and could have popped down with them. However, it seems you have jury-rigged the essentials of a pulse generator and logic probe. It is looking as though your BOB is Kaputski. PM me if you want to borrow.



Page 1 of 2 12 LastLast

Similar Threads

  1. RFQ: I am looking for work as cnc operator.
    By krystiankania in forum Projects, Jobs & Requests
    Replies: 0
    Last Post: 13-02-2014, 02:48 PM
  2. Poorly siemens inverter, wont switch on.
    By jonisonvespa in forum Routers, Spindles & Controllers
    Replies: 7
    Last Post: 06-12-2012, 03:45 PM
  3. Work in Norway
    By Protech HR in forum Opportunities Available & Sought
    Replies: 0
    Last Post: 11-09-2012, 09:12 AM
  4. WANTED: Frame work
    By D-man in forum Items Wanted
    Replies: 3
    Last Post: 30-12-2011, 08:03 PM
  5. NEW MEMBER: Back to work!
    By Edge in forum New Member Introductions
    Replies: 4
    Last Post: 19-08-2010, 10:57 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts