Page 1 of 2 12 LastLast
  1. Hi all, I'm nearly ready to test my table now so i thought i'd get the board hooked up to mach3 and get the e-stop, limit and spindle/torch signals working and debugged.

    The inputs are fine and perform as needed but i have no output to trigger the relay on the breakout board.

    If i reboot the PC, the relay energises and stays on so I'm guessing the LPT port, cable and board/relay are all good.

    As soon as i load mach3, the relay drops out and i cannot get it to re-energise again.

    The leaflet says its on pin 9 and i have mach3 set for Output1 on pin 9 and spindle fwd/rev to #9

    Any ideas as I'm stuck right now and can't progress.


  2. Just tried a fresh install on another PC, different make but exactly the same behaviour.

  3. #3
    Do you have a link to the breakout board ? also what is the relay for on the board ?
    As a complete stab have you tried inverting the pin in Mach3 port&pins settings ?
    Also does the board have a charge pump ? have you set this up in Mach3 or is there a link on the board to force it on all the time ?

  4. Hi it's eBay item 121246794423

    Tried active high or low, no change.

    no idea about charge pump, not mentioned in manual, just says spindle relay is on pin9, I want to use this relay to turn my plasma torch on/off.

  5. #5
    I think we are going to need some more information,

    Assuming you have had no life whatsoever yet from your bob or steppers

    unplug the parallel from the bob, if you google the pin layout for a standard parallel port, put your voltmeter across any of the ground pins, ie pin24, and the other lead to pin9 (you may need to exercise some paper clips)

    see if the pin goes high (ie 3.3v) and low 0v when you send the signal from mach

    I bet your computer is not even sending the signal properly yet, and therefore your problem lies in the mach setup as opposed to the bob.

    either way we need some more information on the question your some screen shots of the various pin layouts in mach

  6. Hi

    if I reboot the PC, when it comes up, the relay will turn on so the lead, bob and relays re all working ok.

    as soon as I load mach3 it turns off and I can do no more with it, I don't even have to press reset, it kills it as soon as mach loads up.

    i can't post pics as it's at work, but I have followed the setup leaflet from the bob supplier, relay is on pin 9 so they say.
    Last edited by Davek0974; 29-01-2014 at 07:43 PM.

  7. #7
    Have set the enables to pin 1 in the outputs.?

  8. Quote Originally Posted by JAZZCNC View Post
    Have set the enables to pin 1 in the outputs.?
    Yes that has been done..

  9. #9
    Well the relay is designed to be turned on and off otherwise how would you turn the torch on and off. So with that in mind how are you trying to turn the relay on once Mach3 has loaded ?
    Last edited by EddyCurrent; 29-01-2014 at 10:05 PM.

  10. I have set output 1 to pin 9
    spindle fwd/rev to output 1
    issue m3/m5 or toggle the torch on/ off in mach.

Page 1 of 2 12 LastLast

Similar Threads

  1. tree problems!
    By kingcreaky in forum Woodwork Discussion
    Replies: 8
    Last Post: 02-06-2014, 11:35 AM
  2. F-Engrave problems
    By cropwell in forum CAD & CAM Software
    Replies: 29
    Last Post: 29-06-2013, 02:48 PM
  3. problems since update
    By motoxy in forum General Discussion
    Replies: 6
    Last Post: 02-11-2012, 05:14 PM
  4. NEW MEMBER: MDF Problems
    By MrWiz73 in forum New Member Introductions
    Replies: 4
    Last Post: 30-12-2011, 11:39 PM
  5. homing problems in mach3
    By johngoodrich in forum Artsoft Mach
    Replies: 2
    Last Post: 17-09-2011, 07:28 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts