Page 1 of 5 123 ... LastLast
  1. #1
    Hi,

    I just received this sensorless vector VFD: HUANYANG Vector Control Drive SL series SL 222EE 2.2KW 220V 3HP VFD inverters 2200watt frequency converters spindle inverter-in Inverters & Converters from Electrical Equipment & Supplies on Aliexpress.com (the link to the manual: http://www.soonwell.com/ebay_file/us...ter-Manual.pdf ) and I'm having problems setting it up correctly with my Chinese 2.2kw spindle.

    First I tried to set it up for the sensorless vector mode.
    After resetting to default settings I set the following settings:
    P0.00 -> 0 (Sensorless vector control)
    P0.01 -> 1 (trimpot as frequency command source)
    P0.13 -> 400 (Maximum output frequency)
    P0.14 -> 400 (Upper frequency limit)
    P0.15 -> 120 (Lower frequency limit)
    PB.02 -> 2.2 (Motor rated power)
    PB.03 -> 400 (Motor rated frequency)
    PB.04 -> 24000 (Motor rated speed(RPM))
    PB.05 -> 220 (Motor rated voltage)
    PB.06 ->10 (Motor rated current)

    Then I ran autotuning (PB.00 -> 1)
    After autotuning finishes I try to start it and it does 2-5 jerky turns and then stops. Changing speed (frequency) with keys or trimpot doesn't do anything.

    Then I tried to configure it in the V/F mode.

    After resetting to default settings again I set the following settings:
    P0.00 -> 0 (V/F mode)
    P0.01 -> 1 (trimpot as frequency command source)
    P0.13 -> 400 (Maximum output frequency)
    P0.14 -> 400 (Upper frequency limit)
    P0.15 -> 120 (Lower frequency limit)
    PB.02 -> 2.2 (Motor rated power)
    PB.03 -> 400 (Motor rated frequency)
    PB.04 -> 24000 (Motor rated speed(RPM))
    PB.05 -> 220 (Motor rated voltage)
    PB.06 ->10 (Motor rated current)

    With these setting it works at maximum RPM (24000) but when I lower the speed with the trimpot it slows down and then the speed begins to oscillate slightly, current rises from 1.8A to ~7A and then the inverter trips with error OC3 (overcurrent when constant speed running).

    Any help or advise will be greatly appreciated!

  2. #2

  3. #3
    Hardly so. It discusses a different vfd model line with different settings and without sensorless vector control.
    I have such (V/F control only) vfd model as well and it works fine.

  4. #4
    This is for Vector Speed mode only.

    I've been having problems myself with a different drive and spindle but this is partly how it was solved.

    My spindle motor plate said;

    V=220
    A=9.5
    Speed=24000
    Freq.=400
    kW=2.2

    So that's what I put in the VFD, however I was advised to change the VFD parameters to this by the manufacturers and it worked;

    V=110
    A=9.5
    Speed=12000
    Freq.=200
    kw=1.1

    It's to do with field weakening.
    Also it would only work with the VFD switching frequency set to 16kHz
    Make sure accel and decel are not less than 5 seconds, mine liked 10 seconds best, now run the auto tune.
    Last edited by EddyCurrent; 29-01-2014 at 11:35 PM.

  5. The Following User Says Thank You to EddyCurrent For This Useful Post:


  6. #5
    Do you use your vfd/spindle in vector mode?

  7. #6
    Yes, it looks like I was editing my post while you posted in the meantime, these settings are for vector speed mode only.
    Last edited by EddyCurrent; 29-01-2014 at 11:37 PM.

  8. #7
    What type of vfd you have? In mine, after running autotuning I get 0.1 in both Motor leakage and Motor mutual inductance. I can manually change Motor mutual inductance but it allows me to change Motor leakage inductance only between 0.0 and 0.1 although the manual says it can be changed between 0.1 and 6553.5
    What inductance do you get after autotuning?

  9. #8
    I'm using an ABB drive, it does not have those parameters. As I understand it, because of the way these spindles are built they are compact and have low inductance, this can confuse the autotune. One idea offered to me was to connect an output choke to increase the inductance.

  10. #9
    Hm, interesting. I will try your suggestions. Thanks!
    Is anybody using the same line or similar vfd? Apparently there is bunch of vfds from China with similar settings naming. They probably use the same hardware/software base.

  11. #10
    Sadly, it didn't help. The best it does in the svc mode is that it rotates with jerks with 1-5rpms stopping intermittently regardless of speed/freq I set with the trimpot.
    So it doesn't work in svc mode at all and trips in v/f mode if frequency is below 120Hz.
    The same motor works fine with my Huanyang v/f only inverter from ~1hz up to 400Hz which means that the motor itself is fine.

Page 1 of 5 123 ... LastLast

Similar Threads

  1. Build Log: Servo Drive and VFD with vector control
    By Jonathan in forum Electronic Project Building
    Replies: 17
    Last Post: 05-04-2015, 07:58 PM
  2. Need help with a sensorless vector VFD and 2.2kw motor.
    By kajuk in forum Spindles & Drive Motors
    Replies: 0
    Last Post: 29-01-2014, 06:09 PM
  3. Vector Linker , thermic cutting
    By CNCtoolsWorld in forum Manufacturer News
    Replies: 0
    Last Post: 28-02-2013, 04:55 PM
  4. bitmap to vector conversion
    By GEOFFREY in forum Computer Software
    Replies: 16
    Last Post: 29-12-2012, 06:32 PM
  5. Vector graphics AKA CAD for free
    By m.marino in forum Computer Software
    Replies: 1
    Last Post: 15-01-2009, 02:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •