Page 1 of 2 12 LastLast
  1. #1
    I have set up my cnc 3040t with mach3, when I open jog screen every axis moves ok . when I use p.c keyboard everything moves ok . when I open roadrunner g code in mach3 and send it to my cnc machine very slight movement in a very small area can any one help please advise will be very much appreciated indeed ...john..

  2. #2
    It sounds like everything is okay but the roadrunner is very small so looks like the machine is just twitching. Have you set up your Mach3 'steps per' ?

    Read this; http://www.mycncuk.com/threads/7871-...1514#post61514

    then watch this; http://www.youtube.com/watch?v=EVrqObwaAF4
    Last edited by EddyCurrent; 24-09-2014 at 10:13 AM.
    Spelling mistakes are not intentional, I only seem to see them some time after I've posted

  3. #3
    Eddy The road runner is not small it's quite large it's just using imperial units and you have tried to cut it with Metric units so appears small.

    This will most likely be the problem here.
    If you want to use Imperial units then Go to Config menu and Native units and see if it's set to Metric units.?
    If so then you'll need to change and restart Mach3.
    Then go into Motor tuning and change the steps per. What ever is entered in steps per just multiple by 25.4.

    If you just want to see the road runner cut larger but don't want to change the units then just use the Scale Axis feature and type 25.4 in each axis Scale Dro.
    You'll find this at the side of the Green DRO box with coordinates in it. Click in it and type 25.4 and push enter, you must push enter or doesn't happen.

    WARNING Doing this remember to reset the Scale factor to 1 before cutting other parts or every thing will be sacled 25.4 times.!! . . .Thats why it will flash yellow to warn you.!

    To be honest I don't think you have enough room to cut the road runner full size on 3040 so just set the sacle factor to say 5x and that will make it big enough to see cut.
    Last edited by JAZZCNC; 24-09-2014 at 10:48 AM.

  4. #4
    thanks for the info got it moving ok but it makes a hell of a squealing noise any thing else I should alter ...thanks for all the info very much appreciated indeed..john

  5. #5
    Quote Originally Posted by hoggy View Post
    thanks for the info got it moving ok but it makes a hell of a squealing noise any thing else I should alter ...thanks for all the info very much appreciated indeed..john
    Not enough info to help John.? Where does the squealing seem to be coming from.? Problems like this are quite hard to diagnose thru words would it be possible to take a video.

    Will need to know at least how the machine is setup in software. So native units and Steps per, velocity, acceleration.
    Also details on the electronics. Does it have the 3 axis all in one board or the individual drives.? Pics would help.

  6. #6
    Quote Originally Posted by JAZZCNC View Post
    Eddy The road runner is not small it's quite large it's just using imperial units and you have tried to cut it with Metric units so appears small.
    I meant it looked small to the OP

    It just shows how naff g-code files are when the units are not specified in a file header, it's a fundamental principle that when 'values' are used they must be given a 'unit' or else they are just meaningless numbers.

    e.g. http://articles.latimes.com/1999/oct/01/news/mn-17288
    Spelling mistakes are not intentional, I only seem to see them some time after I've posted

  7. #7
    native units inches....steps per 12800...velocity 1999.8....acceleration 200....steps pulse10...dr pulse 3....3 axis all in one board hope this helps..john..

  8. #8
    squealing seems to come from all the axis,s

  9. #9
    Quote Originally Posted by hoggy View Post
    squealing seems to come from all the axis,s
    Yes but is it the motors or linear bearings or screws.?

  10. #10
    its not the motors or screws I think it is the linear bearings..john..

Page 1 of 2 12 LastLast

Similar Threads

  1. Mach3 PC problems, help please....
    By Davek0974 in forum Plasma Table Machines
    Replies: 13
    Last Post: 30-01-2014, 07:05 PM
  2. Need repacement controller for CNC 3040
    By RoyT in forum Control Hardware & Systems
    Replies: 4
    Last Post: 22-01-2014, 06:16 PM
  3. Ebay 3040 issue with mach3 - incorrect scale when machining?
    By Wayne Kinney in forum Artsoft Mach
    Replies: 6
    Last Post: 04-03-2012, 12:17 PM
  4. NEW MEMBER: New Member with a 3040 CNC
    By Tug in forum New Member Introductions
    Replies: 7
    Last Post: 26-09-2011, 12:15 PM
  5. homing problems in mach3
    By johngoodrich in forum Artsoft Mach
    Replies: 2
    Last Post: 17-09-2011, 08:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •