1. #1
    RoyT's Avatar
    Lives in Plymouth, United Kingdom. Last Activity: 12-12-2014 Has been a member for 3-4 years. Has a total post count of 6.
    Hi have installed 3 axis TB6560

    All seems OK BUT when I power up the TB6560 controller the spindle starts immediately even if PC is off line.

    Then when I run Mach 3 Gcode. Spindle positions OK ...plunges to begin cutting. ...then it stops turning.

    Any idea please ?

  2. #2
    Check your board at what pin is the output to the spindle, mach 3 settings, ports, output signals, find the output pin number and tick or untick "active low"

  3. #3
    Quote Originally Posted by RoyT View Post
    All seems OK BUT when I power up the TB6560 controller the spindle starts immediately even if PC is off line.
    It sounds like it's wired wrong at the board because it's doing it while PC is off so Mach3 isn't in control. Chances are the board use's a relay and it's wired thru the wrong contact. It should be wired thru NO (normally open) contact so then Mach3 sends a signal to the relay to change switch state and closes the contact starting the spindle. This has been wired wrong way round using the NC (normally closed) so power is allowed to pass thru to the spindle soon as you turn on the TB6560.!!! . . . . . .!!!VERY UNSAFE!!! . . . . Mach3 then turns it off by changing the output pin state when it see's M3/M5 command in g-code.

    So swap the relay contact to NO and you should be good to go. You won't need to change the pin active state in outputs. What Silyavski suggested would work but it's not correct as the spindle shouldn't start when board is powered. Again VERY DANGEROUS and I would look at how you have wired regards safety and E-stop etc.
    Last edited by JAZZCNC; 28-09-2014 at 09:49 AM.

  4. #4
    Quote Originally Posted by JAZZCNC View Post
    What Silyavski suggested would work but it's not correct as the spindle shouldn't start when board is powered. Again VERY DANGEROUS and I would look at how you have wired regards safety and E-stop etc.
    I agree, i just thought he messed with the Mach 3 screen or something happened there. As you say very inadvisable if that not the case.

  5. #5
    RoyT's Avatar
    Lives in Plymouth, United Kingdom. Last Activity: 12-12-2014 Has been a member for 3-4 years. Has a total post count of 6.
    Thanks for the replies. Seems because of spindle voltage I need to add a relay. It's an extra to the package I bought.

  6. #6
    There's a load of similar TB6560 boards but one on Ali Express said this;

    "Relay spindle interface - Outputs Max. 36V 7.5A for spindle motors or coolant pump (only one device can be powered by this output!) "

    It already had a relay on board but if you say it also needs another external relay then that's fine but like JAZZCNC said if you are using the wrong terminals i.e. NC instead of NO you will maybe have the same problem once it's connected up.
    Spelling mistakes are not intentional, I only seem to see them some time after I've posted

Similar Threads

  1. Chinese 300W DC spindle - is the spindle shaft grounded?
    By HankMcSpank in forum Spindles & Drive Motors
    Replies: 44
    Last Post: 26-11-2016, 07:25 PM
  2. Replies: 0
    Last Post: 13-11-2013, 07:50 PM
  3. Driving a Chinese spindle VFD from mach3
    By jcb121 in forum Tool & Tooling Technology
    Replies: 5
    Last Post: 14-08-2013, 10:35 AM
  4. eBay: UIM2901-5A Mach3 breakout board with spindle speed control
    By Fivetide in forum Items On eBay UK
    Replies: 0
    Last Post: 05-02-2013, 07:25 PM
  5. FOR SALE: Mini Mill spindle motor + controller etc
    By pjm in forum Items For Sale
    Replies: 1
    Last Post: 22-06-2010, 07:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •