Page 1 of 4 123 ... LastLast
  1. #1
    Hi everyone,
    I've got a problem with my small KX1 mill that has a USB controller in it. I've had the mill for a while now, but due to circumstances I won't get into I haven't really used it until recently.

    Basically I set myself up to make my first part today. I split the various operations into different gcode files so I could have a bit more control over things. Everything was going well except in-between ops I jogged one of the axes in Mach but there was no actual machine movement. I didn't think much of it, thought I might have nudged the cable from laptop to machine or something, so just started again.

    Half way through the second try the emergency stop got tripped but not by me. Ever since it stopped mid cut I have been unable to get it to reset. There was no reason for the stop in the first place. None of the limits have been hit etc (which I have verified by going to the diagnostics panel). The only one lit up is the Estop.

    Things I have tried:

    Thought the switch might be faulty so bridged the wires and checked diagnostics.... nothing.
    Went into pins & config and turned off the estop, which does actually get Mach out of reset, but when jogging the machine, nothing actually happens. Maybe the controller card still thinks there is a problem and won't actually allow any movement.

    I'm totally stumped and would appreciate any help / suggestions.

  2. #2
    Jess's Avatar
    Lives in Leamington Spa, United Kingdom. Last Activity: 08-06-2015 Has been a member for 1-2 years. Has a total post count of 35. Received thanks 2 times, giving thanks to others 0 times.
    Quote Originally Posted by lateAtNight View Post
    Maybe the controller card still thinks there is a problem and won't actually allow any movement.
    Could be; at least the geckodrive controller I have in my machine (not a KX1, sadly) won't power up unless the e-stop terminal is connected to ground (either via a wire or estop button).

    Given that the estop being closed in normal operation isn't necessarily the obvious thing, when you say that you've tested the estop; does that mean that you've got continuity across the estop switch?
    Last edited by Jess; 31-05-2015 at 09:34 PM.

  3. #3
    Hiya, I am unable to help but can I ask what is your opinion of the KX1?

    Has anyone had a KX1 and a Boxford type machine? How do they compare?

    Was the KX1 expensive? (or is it a KX1s?? whats the difference?)

    ANy information would be appreciated! :)

  4. #4
    Jess, thanks for the reply. You're right, NC isn't obvious at first but it makes sense when you start thinking about the safety aspect of it.

    I didn't get the multi meter out to test the switch itself in the end. I did think about it, but instead I tried running a wire between the two estop wires (not the switch) to close the connection (which would be like a functioning estop button) and it did nothing to reset the estop (through the diagnostics panel on mach). So I assumed it wasn't the button... The mystery goes on... Might be being pessimistic, but I think there might be a problem with either the controller card or the breakoutboard... neither of which I have seen because they came with the internals of the machine!

  5. #5
    Bobby, maybe I should get back to you when (if?) I've sorted the problem... Because I'm pretty unhappy that a machine thats only done a few cuts isn't working as expected... But then again it could easily be my own fault / ineptitude. If I went on a rant... well, that'd just be unfair to Sieg + an egg on face situation for myself :). I will say that for the money I don't think you could do better... but I'm no expert + I haven't really used the machine yet! Price is on arc

    I'll probably blog or something about it when I get a proper feel for the machine.

  6. #6
    Sounds good, Hope you get it sorted soon :)

  7. #7
    Jess's Avatar
    Lives in Leamington Spa, United Kingdom. Last Activity: 08-06-2015 Has been a member for 1-2 years. Has a total post count of 35. Received thanks 2 times, giving thanks to others 0 times.
    There's not a handy manual detailing the internal wiring; any diagnostic lights and so forth? I'd be somewhat surprised if there was nothing at all that indicated a board thinking the e-stop had been pushed.

    If you bought the machine from Arc, then definitely ask them for help; after all, support is one of the major reasons that you'd fork out for a commercial machine!

  8. #8
    No diagram unfortunately... would probably be in Chinese if there was! Haven't looked on the inside of the machine except for the spindle head (which is where the estop button is located). I am going to take out the multi meter and check if there is continuity on the circuit... should have done it in the first place.

    I did contact Arc in the end even though they don't offer support for the machines themselves... its through another website, but long story short Arc did get back to me very quickly and assured me that someone who knows their stuff will be in contact today or tomorrow to try and sort out the problem. Fingers crossed...

    [Edit] Ooops, stand corrected, there is a diagram in the manual!
    Last edited by lateAtNight; 01-06-2015 at 11:20 AM.

  9. #9
    Right, so little update. Got a call from Said I'd need 15 or mins or so to setup. So I got outside, run the power extension out to my shed etc, plug in and jog and the f'ing thing works just as expected! So yeh... egg on face situation kind of. But I will swear on my life I did everything reasonable to convince that machine to come out of estop yesterday... Cycled power on the machine, restarted laptop, changed usb ports (not that that should matter, but gave it a go), exited Mach about 10 times and nothing... but today different story.

    However, he did say that there is a common problem with the plastic guard cover. Its like a little door that covers the cutting tool. It has a switch on the same circuit as the estop apparently. I completely forgot about mine because I removed the plastic cover when i first got the machine... but the circuit that opens and closes with the cover is still there. So I (we) think the estop was being tripped by the guard switch circuit possibly for no reason... I'll see how it goes in the future... if I get any more random estops I might just take the circuit out completely. I don't really know why its there. The guard itself makes sense but having the door on the same circuit as the estop is a little over the top.

    Anyway, I hate wasting peoples time, so I felt like a right noob when I got the call back and had to say the machine was working. But I'm trying to tell myself that I did everything I could yesterday... and that the guard switch is the root of the problem which I wasn't to know about.

    Interestingly though by my reading of the circuit diagram there is only one switch on the estop circuit... but then again I am a noob... and the manual appears to be for the old version of the machine with a parallel port.

  10. #10
    ptjw7uk's Avatar
    Lives in harwich, United Kingdom. Last Activity: 13 Hours Ago Has been a member for 7-8 years. Has a total post count of 370. Received thanks 14 times, giving thanks to others 3 times.
    Just a quick question, should you be using a laptop with mach - Arc recommend a PC.


Page 1 of 4 123 ... LastLast

Similar Threads

  1. Sieg - KX1
    By ptjw7uk in forum Milling Machines, Builds & Conversions
    Replies: 5
    Last Post: 31-07-2016, 10:25 AM
  2. FOR SALE: Sieg x3
    By andris in forum Items For Sale
    Replies: 4
    Last Post: 25-02-2014, 05:32 PM
  3. CONVERSION: Sieg X2 CNC Conversion
    By A11an in forum Conversion Build Logs
    Replies: 17
    Last Post: 16-01-2013, 05:06 PM
  4. Sieg KX3
    By gently in forum Milling Machines, Builds & Conversions
    Replies: 1
    Last Post: 10-09-2011, 10:42 AM
  5. Sieg SX2 in the UK?
    By TheChunk in forum Milling Machines, Builds & Conversions
    Replies: 4
    Last Post: 13-09-2010, 02:00 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts