1. #1
    Hi dose any one know what/is there a difference between

    M542 CNC Stepper Motor Driver 2/4 Phase 256 Microstep Multiple Subdivision 4.5A and the

    CNC Microstep Stepper Motor Driver 2M542 4.2A Controller 24-50V DC Nema17,23,34 apart from the amps

    would i be able to fit the 2m542 as i have the m542 in my machine at the moment. or is the i diffident one i can use (but it must be simple to set up and swap over)

    Thanks for looking and if you can help Tom

  2. #2
    Quote Originally Posted by cockneyrebel View Post
    Hi dose any one know what/is there a difference between

    M542 CNC Stepper Motor Driver 2/4 Phase 256 Microstep Multiple Subdivision 4.5A and the

    CNC Microstep Stepper Motor Driver 2M542 4.2A Controller 24-50V DC Nema17,23,34 apart from the amps

    would i be able to fit the 2m542 as i have the m542 in my machine at the moment. or is the i diffident one i can use (but it must be simple to set up and swap over)

    Thanks for looking and if you can help Tom
    They are affectively the same drive based off or are direct copies of the Leadshine M542. Max voltage capabilty of 50V and 4.2 amps.
    Last edited by JAZZCNC; 07-09-2015 at 07:17 PM.

  3. #3
    Hi Jazzcnc so would i be ok just to swap the m542 for the 2m542 ? thnaks

  4. #4
    I'm pretty sure that would be fine to do Rebel as jazz said their pretty much the same drive with the leadshine being the original, I don't know for sure but I don't think there is much of a premium between the two.

    The voltage specification is MAX 50v, generally it's advised you run them at 40v so you've got a bit of head room for things like voltage spikes.

    Edit: As a side note my 542's are a set of the orginals and I'm pretty sure they are 4.2a, it could be a typo error in the details for the ones you've seen saying 4.5a.

    .Me
    Last edited by Lee Roberts; 08-09-2015 at 09:43 AM.
    .Me

  5. #5
    Quote Originally Posted by cockneyrebel View Post
    Hi Jazzcnc so would i be ok just to swap the m542 for the 2m542 ? thnaks
    Yes they will be fine.
    Doesn't matter what make of drive the important details are the amps and Voltage. Provided the drive has amp setting which matches your motor spec and the voltage rating is 10% more than what your PSU is outputing then they will work fine.

    Even then regards the amps it's not critical they match 100%. For instance if your motors are rated 4.2a and the nearist drive setting is 4a or 4.5 then you'll still be fine. In cases like this you would go to the nearest setting down. This applies to any make or model of drive.

    The important part is the voltage. Never run the drives at there maximum rating and leave a safety margin of aprox 10%. This ensure you don't fry the drives from return energy the motors create when de-accelerating.
    Last edited by JAZZCNC; 08-09-2015 at 03:04 PM.

  6. #6
    thanks for your help on this i get them ordered up and hope for the best lol

Similar Threads

  1. NEW MEMBER: Hi Guys
    By TECNC in forum New Member Introductions
    Replies: 0
    Last Post: 22-01-2014, 01:15 PM
  2. NEW MEMBER: Hello to you Guys
    By Ballot in forum New Member Introductions
    Replies: 2
    Last Post: 01-10-2009, 06:42 AM
  3. NEW MEMBER: Hi guys
    By cookster in forum New Member Introductions
    Replies: 4
    Last Post: 02-07-2009, 08:49 AM
  4. NEW MEMBER: Hi Guys
    By Wotsit in forum New Member Introductions
    Replies: 0
    Last Post: 13-06-2009, 01:10 PM
  5. NEW MEMBER: hi, guys!
    By wendelius in forum New Member Introductions
    Replies: 1
    Last Post: 11-06-2009, 07:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •