Page 1 of 3 123 LastLast
  1. #1
    I have no more ideas for my problem ... PLEASE HELP !!!

    What I want to eliminate .... When I moving Y axis by JOG ... after 10 - 20 or 30 cm of movement ... and when I hold the stepper motor by hand .. I fill strange, fast, single motor stall for very small period of time . This is as losing steps ..... When add dial indicator to the axe after some movements .... I lose 0.1 mm linear accuracy ... for 1-2 and more hours will be about 5 mm .... maybe

    The sound is like a little, fast "knock" ....

    What I did to eliminate the problem, noise .. losing steps ...
    I tried many combinations

    - 2 PC with Mach3 + LPT to the drivers. ( Acer 2 GB, 3 GHz.... Win XP .. ) and Cel 2.4 GHz, 256 MB ... Win XP
    - 2 types of drivers - DQ860MA + Purelogic driver PLD8220-G2
    - 2 power supplies ...
    - 3 types of stepper motors - nema 23 - and 34 x 2...
    - long shielded cables .. and short ...ones .
    - Ground pipe in earth with cable to all shields .... cases ....
    - tried all BIOS LPT modes EPP etc ..
    - kernel mode - 25 and one level up KHz
    - LPT direct cable to driver and thru BOB PCB card ....

    With single G code - Y500 F500 .. after some mm I fill the same issue ...

    When unattached motor is on the table ... the problem is the same ...

    I have single phase 220 AC voltage ....

    If someone have any ideas ... wiring drawings - please send it ... THANK YOU !!

    Last edited by emilvv; 17-09-2015 at 01:14 PM.

  2. #2
    With all the different hardware options you've tried without resolving the issue I'd guess that something may be amiss in your motor tuning, you can have problems with too fast or too slow and if acceleration is too high or too low.

    - Nick

  3. #3
    I had this problem a long time ago and it was caused by running the all-in-one system3 driver/Bob board at 30V. Dropped to 27V fixed the problem.
    But you are using good seperate drivers so should be ok. What Bob are you using and what voltage is going to the drivers? Is it overheating?
    Also tighten all screw terminals
    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  4. #4

    Problem is not resolved ... But I have one more issue to check .. this evening .... :)

    My motors acts like -
    ( only on 200 .. 300 mm of movement .. not on every rotation .. )

    I have XP optimisation.txt file with step by step guide how to setup PC before Mach3 installation ... but maybe I miss this step for switching to standard PC .... and this cause this signal spikes on LPT - missing steps and stalling for small periods ...

    So, I will check and if this is a problem will post the results .....

    I have 2 core CPU and I hope switching to Standard PC ... will fix the problem ....



  5. #5

    Problem not resolved :(

    What I did ....

    1. Reinstalled XP PRO ...

    2. Applied all steps from XP optimization.txt ....

    3. Installed Mach3 + licence file

    Started, but the same problem ... on every 200 - 300 mm movement motor 'knock' for a less than a second ... maybe 0.1 s ... :( I can feel the 'knocking' by my hand .....

    Attached Win XP device manager screens - why I have 2 standard PC in my device manager .... is it normal ???

    Any ideas .. ? Please help

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1.JPG 
Views:	56 
Size:	58.3 KB 
ID:	16054   Click image for larger version. 

Name:	2.JPG 
Views:	53 
Size:	56.3 KB 
ID:	16055   Click image for larger version. 

Name:	3.JPG 
Views:	52 
Size:	56.3 KB 
ID:	16056   Click image for larger version. 

Name:	a 001.jpg 
Views:	53 
Size:	159.6 KB 
ID:	16057   Click image for larger version. 

Name:	a 003.jpg 
Views:	62 
Size:	105.1 KB 
ID:	16058  
    Attached Files Attached Files
    Last edited by emilvv; 15-09-2015 at 12:08 PM.

  6. #6
    What voltage do you have coimng out of the PP.? This problem sounds very much like PP is low power probably 3V type. This will cause the problem you are having because there isn't enough voltage difference between HIGH/LOW.

    Also one more thing that can cause this and in some way related to the above is if your Step pulse is on the wrong edge of the pulse. ie: On the down slope(falling edge) when the controller is pulsing on the up slope (rising edge). This affectively puts the timing out and you'll loose one step with every direction change.
    To test this for each Axis just write some G-code which moves the axis Back n forth small amounts but 1000's of times very fast.
    G0 x10

    Copy and paste into a file to make several 100 lines. Make a Mark before starting and run the file. It should return and if it doesn't then you are on the wrong edge of the pulse.

    Some drives will let you select the rising or falling edge, Some won't. To Force or change the edge just toggle the Active Low in Motor outputs. This will reverse the motor direction. So goto Homing and Limits and Click Reversed for that axis.

    Try and let us know.?

    Or better still do your self and machine a favor Dump the PP and get your self a external motion controller.!! . . . You won't regret it.
    Last edited by JAZZCNC; 15-09-2015 at 03:51 PM.

  7. #7
    My understanding of the operation of the drivers is that the direction pulse should overlap the step pulse at both ends, so whether direction is set one way or the other, High Low, 0v 5v whatever it should be in a settled state before the step pulse, then whether it is a positive going pulse or negative one, both the leading and trailing edges are within the direction state. I would imagine that if different protocols are used for step and direction then results would be unpredictable. As would happen when the timing of pulses is in error, then direction would not be properly set. - Hence missing steps.
    JAZZ - correct me if I am being Naive

  8. #8
    It's more to do with the Controller issuing the step pulse on the rising edge and the drive set to process it on the falling edge there becomes a timing issue so when a direction change occurs the step is in front of the Dir and a step or MS is lost on each change of direction.

    Having the wires on the drive wrong way around will also cause this. So Step + being connected to Step- on BOB. Also a BOB with slow Opto's could cause this but seen has the OP tried direct to drives I reckon not.!
    Last edited by JAZZCNC; 15-09-2015 at 07:13 PM.

  9. #9
    is this happening only to the Y axis?
    And I didn't see what drivers you are using.

    P.S. Saw the drivers in the first post.
    Last edited by Dragonfly; 15-09-2015 at 07:57 PM.

  10. #10
    Quote Originally Posted by JAZZCNC View Post
    It's more to do with the Controller issuing the step pulse on the rising edge and the drive set to process it on the falling edge there becomes a timing issue so when a direction change occurs the step is in front of the Dir and a step or MS is lost on each change of direction.
    I think that is what I said i.e direction not settled before step.

Page 1 of 3 123 LastLast

Similar Threads

  1. New machine bogging down / missing steps
    By James123 in forum Gantry/Router Machines & Building
    Replies: 16
    Last Post: 18-12-2014, 11:02 PM
  2. clunks / missing steps - DM856 and single pulse operation
    By dsc in forum Motor Drivers & Controllers
    Replies: 37
    Last Post: 09-12-2013, 01:22 PM
  3. mach3, steps & microstepping
    By martin54 in forum Artsoft Mach
    Replies: 10
    Last Post: 10-04-2013, 07:00 PM
  4. Strange problem, possibly missing steps?
    By Philly in forum Chinese Machines
    Replies: 5
    Last Post: 26-10-2012, 05:36 PM
  5. Missing Steps + Stalling X-axis
    By danielbriggs in forum Linear & Rotary Motion
    Replies: 5
    Last Post: 02-09-2010, 01:59 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts