Page 2 of 3 FirstFirst 123 LastLast
  1. Quote Originally Posted by cropwell View Post
    I think that is what I said i.e direction not settled before step.
    I didn't read it that way at first but reading again then yes same thing really.!! Time is shortened and next signal comes along before gets chance to complete last thing so something gets dropped at each direction change.! . . . . . I've eaten since then so my brains fired up again. . Lol

  2. #12

    THANK YOU for all of You.

    Problem is not resolved ... :(

    Yesterday i tried with LinuxCNC live DVD . 2.7.

    It is easy to try but the problem is the same !

    I moved only one ( Y ) axe because I want to fix the problem.

    I moved only in one direction .... from Y = 0 to Y = 600 ....

    When I moved Y ... after 200 mm ...300 mm I am receiving that motor knock ...

    In Linuxcnc - the same situation ... I tried many configurations .... for STEP pulses, driver setup ( I mean microstepping modes ... )

    A little bit better on slow speeds ..... and 400 steps per / rev .... but that is not good idea ..

    I have to check LPT voltage .. Also will try to drive the drivers by arduino .. to change speed and to prove driver quality ...

    Any ideas are welcome ....

    Thank you in advance,


  3. #13
    Well first of all you seem to be jumping all over the place and not concentrating on trying to sort the problem out in a logical way. It is no use just trying random changes. So take it one step at a time giving clear and concise feedback.
    Some good pictures of the machine would help, are you using ball screws or screwed rod etc? You have already been asked to check the pp voltage out put. ie is it 3.3V or 5V but you have not answered. This might just be a simple pp and bob problem.
    Sorry to be a bit harsh. ..Clive

  4. #14
    Get an external motion controller. The parallel ports on Acer and Asus motherboards are not great, I have tried both of them and know. If you do not want to afford a motion controller, get a second PCI parallel port and see what you get but chances are you will still be having issues.


    Stocking more goodies than just Smoothsteppers

  5. #15
    When I moved Y ... after 200 mm ...300 mm I am receiving that motor knock ...
    Does it happen at different points when you apply different speed or steps per mm?
    If at the same point then check the mechanics.

  6. #16
    I had a knock on my X axis today when changing direction sometimes, turns out the grub screws holding the pulley on the stepper shaft were loose and slipping. I'd put one jnto the stepper shaft keyway and thar was rattling back and forward....until it too slipped.


  7. #17

    Clive, maybe you are right ... I have free time just to check LPT voltage - it is 3.3v on both PCs ...

    I didn't check it before, because using one of the PCs with my bigger CNC machine I didn't have any problems for years !! ...
    The same drivers on all machines !! ..

    But when using it in another place / room I received the problem with both PCs -

    So .....

    Machanics is not an isuue ... motors knock on the table :) .. not connected to the machine ...

    My plan - to add 6N137 fast opto - as opto and also as logic level 'converter' .. :)

    ( also I have them on 'stock' :) )

    When I finish will write here the results ....

    Thank you all of You !!


  8. #18
    ... I have free time just to check LPT voltage - it is 3.3v on both PCs ...

    I didn't check it before, because using one of the PCs with my bigger CNC machine I didn't have any problems for years !! ...
    The same drivers on all machines !! ..
    Ah but was you using the same BOB. The better BOB's level shift the 3.3V back up to the 5V and then generally all is well. Good luck with the investigation . Clive

  9. #19
    EdingCNC is quite a nice controller. Also affordable. Will work witout issues in Ethernet or USB. This takes little setup and works good.

  10. #20

    Problem solved. :) Thank you for all your help.

    The PC LPT port generate strange pulses .... from 4000 ns to 300 000 ns.... ( based on linuxcnc tests .. )

    Why I not saw the problem ..

    I tested all the electronics with my another PC ... ( also with the same problem .... but a little bit better !!! ), I used another PC with CNC machine for manu years, but just for some small cuts .. with perfect shape ... )

    So, I suppose my first PC is OK .... with both PC s .. the problem exists .... so the problem is in the electronics ....

    But when I tested it with NE555 generator .. motors are fine !!! So ... I became almost with no idea what to do ..

    I grounded all, used 74HCT245 ... 6N137 ... to change the logic voltage levels .... and finally on the last started the linuxcnc
    for N-th time and saw strange situation ....

    After start i have 4000 ns step period ... and after a while ... 1 second ... it increased to 300 000 ns.....
    after reset statistics button .... the same situation ...

    Mach3 doesn't see the wrong signals .... message is "System excellent" !!! :(

    I didn't investigate to check signals by scope in time period ... I have no time for that ...

    So, please fine attached first cut picture - 4 mm carbide tool in wood ..... Sorry I am not woodmaker ... it is just a test

    Have a nice day to all of you,

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	11.jpg 
Views:	32 
Size:	98.7 KB 
ID:	16176   Click image for larger version. 

Name:	22.jpg 
Views:	39 
Size:	141.6 KB 
ID:	16177  

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. New machine bogging down / missing steps
    By James123 in forum Gantry/Router Machines & Building
    Replies: 16
    Last Post: 18-12-2014, 11:02 PM
  2. clunks / missing steps - DM856 and single pulse operation
    By dsc in forum Motor Drivers & Controllers
    Replies: 37
    Last Post: 09-12-2013, 01:22 PM
  3. mach3, steps & microstepping
    By martin54 in forum Artsoft Mach
    Replies: 10
    Last Post: 10-04-2013, 07:00 PM
  4. Strange problem, possibly missing steps?
    By Philly in forum Chinese Machines
    Replies: 5
    Last Post: 26-10-2012, 05:36 PM
  5. Missing Steps + Stalling X-axis
    By danielbriggs in forum Linear & Rotary Motion
    Replies: 5
    Last Post: 02-09-2010, 01:59 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts