Page 1 of 4 123 ... LastLast
  1. #1
    Wondering if anyone knows why my stepper motors keep stopping and starting when a program is running but in jog mode they run fine. Only new so Mach3 might not be set up ok.

  2. #2
    Chaz's Avatar
    Lives in Ickenham, West London, United Kingdom. Last Activity: 18 Hours Ago Has been a member for 4-5 years. Has a total post count of 973. Received thanks 69 times, giving thanks to others 42 times.
    Quote Originally Posted by Davo242 View Post
    Wondering if anyone knows why my stepper motors keep stopping and starting when a program is running but in jog mode they run fine. Only new so Mach3 might not be set up ok.
    What code are you running through them? Can you show a vid of what's happening? Any details on the setup will be good too.

  3. #3
    It's G-code. I won't be able to get a vid until tomorrow but will do asap. I have them set as is in the manual that came with them.

  4. #4
    Quote Originally Posted by Davo242 View Post
    Wondering if anyone knows why my stepper motors keep stopping and starting when a program is running but in jog mode they run fine. Only new so Mach3 might not be set up ok.
    Not giving us much to go on here Davo we are not Mystic Meg's.? Could be lots of things.

    Explain better exactly what happens ie: Does it stop completely or stop/start. On which axis and at what point of travel on machine, same place or random spots. When or where in the code, beginning, middle end.? . . . . Video better still.

    Give details of the Motor tuning in Mach3 for each axis.
    Give Info regards drive model and Micro stepping, PSU voltage, motor size/model.
    Parallel port or external motion control.

    Give some indication to size and type of machine.

  5. #5
    Click image for larger version. 

Name:	CNC1.jpg 
Views:	47 
Size:	10.5 KB 
ID:	17009Click image for larger version. 

Name:	CNC2.jpg 
Views:	45 
Size:	10.2 KB 
ID:	17010Click image for larger version. 

Name:	CNC3.jpg 
Views:	41 
Size:	10.0 KB 
ID:	17011Click image for larger version. 

Name:	CNC4.jpg 
Views:	41 
Size:	8.6 KB 
ID:	17012Click image for larger version. 

Name:	CNC5.jpg 
Views:	52 
Size:	13.1 KB 
ID:	17013Name:  video_57.png
Views: 113
Size:  4.3 KB

  6. #6
    Chaz's Avatar
    Lives in Ickenham, West London, United Kingdom. Last Activity: 18 Hours Ago Has been a member for 4-5 years. Has a total post count of 973. Received thanks 69 times, giving thanks to others 42 times.
    The vid is not watchable and the pics too small. Dont use the 'save locally' option, it makes the pics tiny. If you can get the vid on utoob, it will help.

  7. #7
    https://youtu.be/rbJveQTkICA this is a link to a video of the motors

  8. #8
    Click image for larger version. 

Name:	image1.jpg 
Views:	51 
Size:	535.5 KB 
ID:	17024Click image for larger version. 

Name:	image2.jpg 
Views:	48 
Size:	511.8 KB 
ID:	17025Click image for larger version. 

Name:	image3.jpg 
Views:	51 
Size:	573.6 KB 
ID:	17026 hope these are ok
    Attached Images Attached Images  
    Last edited by Davo242; 01-01-2016 at 04:34 PM.

  9. #9
    Ok well first turn the Kernal speed sown to 25000hz you don't need it that high. Going to high here stresses the parallel port.

    Next the fact you are testing on the bench and not fastening the motors down will cause resonance which could be some if not all of the problem.

    Also the Steps per setting how did you come to the figure of 320.? . . . . And What are Micro steps set to on your drives.?

    Are each axis set to the exact same step per figure and tuning.? You must select the Axis on the side bar to correctly display for that axis and then save after every change.

  10. #10
    Thanks for replying

    Ok I will try fastening the motor to the frame tomorrow to see if this corrects the problem.

    The steps per setting I have used is what was outlined in the illustrations provided with both the motors and drivers. The micro steps are set at 1/8. On my drivers this corresponds to off on off.

    Yes I have checked each axis and they are correct.

    I will try and upload pictures of driver.

    Once again many thanks for your time and patience

Page 1 of 4 123 ... LastLast

Similar Threads

  1. stepper motors
    By reefy86 in forum Gantry/Router Machines & Building
    Replies: 4
    Last Post: 06-09-2015, 12:54 PM
  2. Replies: 6
    Last Post: 27-05-2012, 06:06 AM
  3. Help with Stepper Motors
    By Scott in forum Stepper & Servo Motors
    Replies: 8
    Last Post: 04-04-2010, 02:35 PM
  4. rs stepper motors
    By chaz@2b in forum Stepper & Servo Motors
    Replies: 19
    Last Post: 06-08-2009, 11:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •