PDA

View Full Version : Redsail Laser water protection alert



shindax
28-09-2019, 12:46 PM
Hi All,
I hope you may be able to help with this issue. I will try and be as brief as possible
For 10 years I was working in a school as head of DT and we used an E5 Redsail laser.
After 6 years it developed a fault and the company we bought it from came to repair it at a great cost.
A year later it developed a broken wire issue on the x axis and the school decided to purchase a new machine.
At my retirement at the end of last year I asked if I could buy the old machine and they said yes.
The broken wire was easily fixed !
I had the original software (lasercut 5.3) and the softdog dongle/
I then set the machine up in my sged at home.
The software seemed to load ok.
I downloaded a simple file and the machine did a contour, all was good I thought.
However, an error message appeared on the control panel..."WATER PROTECR IS EFFECTIVE"
I checked the pipes from the chiller for kinks and made sure the water was flowing round the tube which
it does well.
I checked the cable from the chiller to the machine and it has continuity.
I see no water sensor on the machine !
I can download files for contouring from the laptop but not set the laser to fire from the laptop and if I do try it ceases to let me download files unless I shut the software and re-open it.
At my wits end I called a repair "specialist" who took 400 from me turned up in a nice jumper with his logo on and didnt seem to know what he was looking for leaving saying he needed to ring his guy in China.
That was 5 days ago and no sign of him since.
The machine seems to be almost there apart from this issue.
The controller is an MPC 6535.
I really hope someone can help what seems to be a simple problem before I bight the bullet and buy a new machine which on my pension will not be easy but I cant just sit in a chair and do nothing plus my wifes jewellery making would benefit greatly.
I apologise for the long message but want to say thank you in advance for any help you may have.
Regards
Dave

m_c
28-09-2019, 01:41 PM
A quick google has found a manual for that controller - http://www.leetro.com/english/down/productcatalog2015/Manual/MPC6565/Hardware%20Manual/MPC6535&6565(DSP5.3)Hardware%20Manual%20En-V1.3.pdf

By the look of fit, the manual example wiring diagram shows the water protection (pin 3 on the input connector) as just being connected to ground. I'm guessing Redsail have added some kind of switch (low water level?) somewhere. It should just be a case of following wiring, to see what has been connected. Or maybe first add a temporary jumper wire at the connector to see if the fault clears, before investigating what the real problem is.

shindax
28-09-2019, 01:51 PM
Thank you so much for your reply.
My electronics is not my strongest point but will have a go.
Do you mean the connector going into the machine or on the controller ?

m_c
28-09-2019, 02:44 PM
The connector on the controller.

This manual has a nice picture on the front cover that shows the connectors - http://www.rabbitlaserusa.com/Manuals/MPC6535HardwareManual.pdf

By the looks of it, it's the terminal marked IN3.

shindax
28-09-2019, 02:51 PM
That's brilliant thanks. As soon as the wife has had enough weekly shopping I will have a look.

shindax
29-09-2019, 10:40 AM
Hi m_c
You are a star.
I have just followed your advice and looking at the controller there were no wires at all in that area at all which i thought was strange as it had worked previously a year ago.
This morning I put in the jump wire as suggested and now the error message has stopped and the control panel is now unlocked.
I have just downloaded a simple file and everything worked fine.
Apart from needing a new tube all is working well.
should I be happy with that or do you think I need to investigate further ?

Thanks again
Dave

m_c
29-09-2019, 06:30 PM
As long as it's working, I wouldn't worry about it.

If it's previously worked like that, I'd guess there is probably a setting buried in the software somewhere to disable the water protection.

shindax
29-09-2019, 07:35 PM
Thanks for your help greatly appreciated just have a software problem now when I try to import a dxf file lasercut 5.3 immediately closes down thanks again for your help gratefully appreciated
Dave