. .
Page 1 of 4 123 ... LastLast
  1. #1

    I am extensively testing the Pokeys57CNC with the hope that price wise it will control all my future creations. As its USB, Ethernet, made in EU and good price, i had high hopes for it.

    So far i have only basically wired it to the machine. No sensors, homing and so. Till now i had a couple of minor problems with it:
    -Something unclear in the manual about the pullup resistors, tried help in the mach3 support forum, received it after at least more than a week . Still not clear what value resistor to use. Hello, i am not an electronic engineer . Ok i figured from other forums 10Kohm
    -Had some other positioning problem, at the end it turned i had not adjusted well the servos. Tried support on their web, opening ticket. Received an answer, which did not help me much . No answer on my follow up question or when i left feedback what the problem was .

    So far so good. Started drilling 500 pieces , each piece 2x15 holes. Just opened a ticket, will see what happens. Bellow is the problem described. I am not saying its not again some mistake of mine somewhere. But i checked the code line by line its correct.

    So my questions are:
    -who else is using this board?
    -any problems?
    -anyone similar problem like mine?

    I still have hopes for this board, may be i am doing sth not right. Furthermore i have a couple of them, not just one. The machine moves well, servos are smooth. Just that tiny problem below that made me loose material for pieces which if i have sold, i could have bought one more board.

    ​Pokeys 57CNC+mach3. All fresh install, latest all before a couple of months. Nothing else on PC. Second network card disabled from windows.

    The problem is very simple. Its loosing X axis position somehow. Program is drilling a horizontal row of 15 holes. I change workpiece and then again repeat. 10 times it does it right. Every now and then instead returning to 0 it returns to ~ X-2, X-3 or X-4mm. I dont see that, push start program button and it screws the holes placement with -2, 3 or 4mm respectively. I rewind, recalculate and start again. Even if i start from X-4, when i recalculate it drills holes right. Until it fucks again the workpiece after 10-15 pieces making exactly the same mistake.
    ​Problem is all happens very fast and i have no time to react to stop process, and even if i do, i am wasting time, which i dont have.

    So it seems mach3 knows exactly where the spindle is at all times, just sometimes it does not move it till the right position X0, Y0, and from there on the error happens. So that means its not motor related, its Pokeys Mach3 thing.

    ​I dont know about Y, as i drill in a straigh line and dont have time to make experimens in the Y direction, though looking at the numbers it does not do that mistake, as Y is always Y0 or some fraction like Y0.0033

    ​On the photos below clearly could be seen what i am talking about. Instead of x-64 what the program says to mach 3, its -x62, When program finishes it is x-2 instead of X0.


    Click image for larger version. 

Name:	pokeys 4.jpg 
Views:	1223 
Size:	1.04 MB 
ID:	18974Click image for larger version. 

Name:	pokeys.jpg 
Views:	1282 
Size:	751.8 KB 
ID:	18975Click image for larger version. 

Name:	pokeys3.jpg 
Views:	1244 
Size:	699.1 KB 
ID:	18976Click image for larger version. 

Name:	pokeys2.jpg 
Views:	1046 
Size:	510.6 KB 
ID:	18977

    project 1 , 2, Dust Shoe ...

  2. #2
    It seems to be popular with Mach4, and they seem to reply quickly on the Mach3 Yahoo group.
    They're probably spending most of their time on Mach4 development these days.
    UCCNC 2022 Screenset

    Mach3 2010 Screenset

    JointCAM - CAM for Woodworking Joints

  3. #3
    Well this tiny board seems to continue to raise higher on my SHIT list, though i am still trying to remain positive. I feel tempted to review it more in detail, but as i am still getting to know it, will take a bit more time to see if its a winner or looser.

    So for the moment that's where i am:

    -support was ok as communication, but did not resolve my issues. Clean installed my PC, read manuals, continued conversations with support, blah, blah. Problem still persisted. Every 1-2 from 10 times it will not go to X0 at end of program and mess a piece.

    So i installed Mach4 trial. I have too many money invested in Mach3 to change programs. Plus i have screens, screens for plasma THC..., so No for the moment. But it worked without problem there. Then back to Mach3. from Pokeys support i previously was urged to install the latest beta plugin that has in their words " same as mach4 communication library" . Still it gave me bigger problems messing with recognising at all the IPs and so.

    At the end yesterday i reread the communication between me and support and at the end figured the problem. Problem was their manual says " add the Pokeys IP manualy and restart" . Seems their plugin automatically finds after restart the IP. And me doing it manually messed up things. Is there somewhere abbreviation for " Update the F"""ng Manual?

    -if you read my build log the cheap chinese relays were not working with this board / could not provide enough power, or i did not figure how. So i had to shell 50 euro for their 8 relay board. Set all today. Everything fine but when i switch on and power the BOB at first there is like 2 sec when all powers on, the relays switch on like crazy. Come on, that is bloody dangerous. Spindle starts and if i had connected sth else...

    -Spindle 0-10V output. I had to read forums hours and hunt the information. No simple set up guide. Come on. Is it so difficult? Just asked them sth. While i have figured what i have to do in the plugin, i still don't know is if i have to change in Mach3 spindle PWM set up and enable spindle from motor tuning window.

    Meanwhile there was no voltage output and i managed to break apart that tiny/ did i say microscopic/ trim pot that regulates the voltage.

    So i have 2 boards, relay board and output board from them. The idea was to power my small machines with sth made in EU, cheap and Ethernet, with enough axis. For the moment this is not to my expectations. I watched people power mill with this board, but hey- what happens atthe first 2 seconds when the relays go crazy?

    So now i have no voltage and i am in a need of separate board / as the second board most probably will be returned to them or sold at ebay/ for the spindle
    project 1 , 2, Dust Shoe ...

  4. #4
    I do feel for you. I feel the problem may lie in the Mach3 plugins as from what I can see there is no longer any support for them.
    Pokeys has been doing a lot of work recently with Mach 4 and the lathe threading problem and they have brought out at least 6 plug in upgrades recently. So just where this leaves M3 users is a bit of a toss up.

    Recently I have taken stock of where I am trying desperately to get a lathe working correctly on whatever is out there.
    Mach3 can't and won't thread without an external controller such as Pokeys but Pokeys won't work on the M3 version. They say it can't be done but CS labs can 'nearly' thread under M3 if you are happy with a run off groove at the end of every thread.

    Why can't M3 thread with an outside controller to pass over to ? We could thread 15 years ago with DOS but with all the brains and computing technology we have now, we can't ??

    Dan Mauch has spent the last 3? months working with Brian at M4 and pokeys to get a lathe to thread and it looks like he's done it but I have to ask myself at what cost ?
    Personally I can't even get M4 working. It won't read a g-code generated in M3 that runs every week on production [ fortunately no threading involved ].

    I look on my shelves at what is there. Two DeskCNC boards that were as useless as Fred Smith's support. The space where two early smooth steppers used to sit gathering dust whilst the Mounties were looking for the programmer who didn't return any emails or support issues for exactly a year. Nearly forgot the NC-Pod that used to do to sleep and disconnect itself from the system.

    A Gecko G-Rex that has got to be the biggest flop in terms of time and money except the 12 yes no typo, twelve, 201 drives that just blew up at switch on and Marriss insisted it was bad motors even though a swap onto a less power drive would carry on running. Made worse 2 years later on CNC zone when he admitted they had a problem with them exploding !!

    Goodness knows how many breakout boards by various manufacturers.

    So to get a lathe working on M4 and remember anything I build I have to support so please no one mention Linux CNC as no customer would buy a system that looks like etch-a-sketch on acid, I need the following.

    A computer 150.00
    A windows license 75.00
    A Monitor 75.00
    Keyboard and mouse 20.00
    Mach 4 license 150
    Breakout board [ decent one ] 125.00
    Pokeys board 120.00

    Power supply. steppers and drivers have not been included in this as they will be needed on any system. Above is what is needed for Mach 4.

    So I reckon a total of 715 before you start setting up and being an unpaid beta tester.

    However times move on and last week this landed on my doorstep.

    Not the best shot with reflected light.

    A two axis complete CNC system, can control 2 axis to industry standard, spindle, pendant and also a tool changer.
    Just add drivers and stepper to complete and stir.

    Also available in up to 5 axis on a sliding price scale.

    This one landed, all duties declared and paid at 387.00

    No contest, we live in interesting times
    John S -

  5. #5
    HI John,

    i was seriously considering Downgrading to LPT before i read your post. if after 6 years in CNC i can not make a board spin the spindle at speed, cut repeatedly 10 elements, switch on and off the relays when i want to...then maybe is better to go back in stone edge.

    "Unpaid beta testers". No, we are more like "willfully Paying Alfa testers"

    So the chinese have done it again? What will you use 2 axis for? laser or plasma? Anyway, how did you find it? Again you are "alfa tester"? Or sb already has it working. Could you provide a link please. I swear here in front of all that if one of these chinese things, say a4 axis works reliably, i will buy 100 pieces for starters and raise the bar so, that anyone in EU will have a serious difficulty to sell his crappy motion control board even for 100 euros. I am so fed up with BOBs. I was very seriously considering these days to raise the question if sb here at forum is capable of designing a board to my specifications so we partner to produce it.
    project 1 , 2, Dust Shoe ...

  6. #6
    Quick reply as going out.

    It was bought as a 2 axis just for a lathe as it can thread properly.
    I have a lot to do with the Chinese as i was heavily involved with them to build the KX1 and KX3 turnkey milling machines.

    The website is here for the different controllers.


    We landed two into the UK last week, mine is on a bench, no machine as yet whilst we sort out parameter settings.
    Steve Blackmore has the other controller temporally fitted to an Orac lathe and he has it jogging and homing already but still has the spindle, toolchanger and encoder to sort out but it's looking good.

    There are some very simple cheaper controllers that can do 4 axis and spindle but not threading or rigid tapping, no encoder feedback.


    Again these are just a stand alone controller, no computer or break out boards needed and just require power supply, drivers and steppers.
    These sell for about 140 to 180 depending on what deal they are doing and shipping.

    I feel that these new controllers are going to be a game changer.
    John S -

  7. The Following User Says Thank You to John S For This Useful Post:

  8. #7
    Well, its official. This board is so buggy that i am done with it. Take a look at the video how the relays are thinking they are controlling disco lights not an industrial machine. Meanwhile the machine is cutting. Thanks god that i took out the spindle control from the relay after dry testing.

    I will contact them and all goes back to them. Will keep that board though as i have to repair the microscopic surface mount trimpot. At the end sb that runs Mach4 could use the board.

    I jumped and bought the DDCSV1 controller. Will see how it goes. Seems promising. Its high time sb to check them out. I looked at some other ones but it seems they had some limit of file size. Not clear, crappy manuals. This one has a good manual . Meanwhile i will try to find english version manual of the more advanced and expensive mill controllers that could tap and so. Another bonus is my wife / on a vacation now/ works directly with chinese manufacturers so we would ask them what controls are they using on their mills.

    John, please update us how the things are going with your controllers, maybe in a separate thread. you bought it for personal use or for integrating in machines ?
    project 1 , 2, Dust Shoe ...

  9. #8
    Hello, I bought the pokeys57cnc and Postep60-265 drivers, a plan to use them for plasma CNC , does anyone use this board for plasma machine ?! The THC I plan to use is miniThc from Russia, it have parallel connection ... As I understand I can connect the parallel THC to pokeys57cnc with IDC26-to-DB25 ribbon cable, but in which port exactly on pokeys57cnc on the one listed db-25 connector with 5 end switches ?!
    Appreciate help and suggestions.

    Sent from my A0001 using Tapatalk

  10. #9
    As you see above improper? grounding or just EMI from servos messed things up with my board and it was doing strange things. Make sure you properly isolate it from noise, cables included.

    About the parallel, its in the manual i believe.

    Take a notice what they say there page 16:
    DB-25 (LPT-port) IO connectorWarning: on PoKeys57CNC v1.1 the pinout is not compatible with the LPT-based stepper drivers sincethe physical pin numbering sequence in PoKeys57CNC v1.1 differs from that of a real DB-25connector. Check the pinout diagrams above.
    project 1 , 2, Dust Shoe ...

  11. #10
    Hi Boyan,

    My name is Dimitris and i am writing you because i did the same mistake... I used 8 pokeys57cnc cards to construct 8 similar 3-axis cnc machines for a customer. I trust these new for me cards because in the past i have successfully constructed a lot of cnc machines, using a tiny mach3 parallel communication board and mach3 software. And i can sure you that these machines are still working perfectly aftes 10 years of working without any kind of problem.
    Now i am really sitting on fire because i have the same problems as you. The axis not always stops in the given position. Sometimes stops correctly and other times (randomly) stops between -1 - +1 mm. My mind its gonna blow.
    Fisrt i had the same problems as you, as i using the extPokeysRelay boards. Finally the problem was the noise. I solve it as i "dress" the wires with a grounded metallic fence (for EMI protection).
    Now i am trying to solve this f*** positioning issue. I am using the Leadshine DS1008 servo drives and as you, i tried to change the PID parameters. The movement of the axis now it seems better but still i have the same positioning problem.
    Could you please advise me how the f*** can i solve this problem? Is something wrong in the mach3 parameters? Is the noise? Must i EMI protect the axis driving wires too?
    Any ideas will be veeeery welcome!!!!!

    Thank you in advance

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Step-Four problems
    By BazzerH in forum General Discussion
    Replies: 8
    Last Post: 18-03-2020, 11:09 PM
  2. Mach3 Problems problems problems.
    By ECCO in forum Artsoft Mach (3 & 4)
    Replies: 18
    Last Post: 09-07-2016, 10:07 AM
  3. Help needed! Servo, MACH3 or Pokeys57CNC whats going on?
    By Boyan Silyavski in forum PoLabs (PoKeys)
    Replies: 5
    Last Post: 23-06-2016, 04:22 PM
  4. tree problems!
    By kingcreaky in forum Woodwork Discussion
    Replies: 8
    Last Post: 02-06-2014, 12:35 PM
  5. NEW MEMBER: MDF Problems
    By MrWiz73 in forum New Member Introductions
    Replies: 4
    Last Post: 31-12-2011, 12:39 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts