. .
Page 3 of 4 FirstFirst 1234 LastLast
  1. #21
    So this is now winding me up
    I have installed the plugins and they now appear in my M4 plugins file

    Click image for larger version. 

Name:	plugins.PNG 
Views:	89 
Size:	109.9 KB 
ID:	29410

    But I have restarted my computer (and M4) and I just get the message as follows.


    Click image for larger version. 

Name:	error message.PNG 
Views:	89 
Size:	48.0 KB 
ID:	29411


    I have just tested this on my office computer but of course no UC100 device is connected

    On the workshop machine (where a UC100 is connected ) I do not get the error message but when I select to configure/select motion device then UC100 does not appear as an option .
    I only see "simulation device" which i presume is part of the M4 software as supplied.

    So where do I find the wisdom which will tell me what I am doing wrong

  2. #22
    Quote Originally Posted by John11668 View Post
    I can make things happen on the screen but it wont do anything with the machine ,(not even Jog)
    My machines have both run in Mach 3 using the UC100 USB controller but nothing in M4 so I am guessing it needs ethernet controller .
    I dont mind the expense as long as it works . Same applies to the license . I guess both of them could be moved forward to my next project .

    Who has used M4 with such a controller and how did it go .
    Have you successfully run a machine on Mach 4 m_c ? and if so with what motion controller
    I have raised a question on the cncdrive forum but they are telling me that the problem is something missing in M4 . Typical when you have two products running hand in hand that if it fails to work each blames the other

  3. #23
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 23 Hours Ago Forum Superstar, has done so much to help others, they deserve a medal. Has been a member for 9-10 years. Has a total post count of 2,822. Received thanks 346 times, giving thanks to others 8 times.
    No I've not.
    I do have a license for it, as I bought it years ago when they done a pre-release offer, but I've never had any reason to run it.
    The only reason I installed it last week, was to check how macros are stored, as somebody was having an intermittent issue with a machine hanging at a certain point, and to tell them where to find the files so we could try and workout what could possibly be causing the problem.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  4. #24
    I have a response from CNCdrive forum which looks authoritative if maybe a bit complicated .
    Will post it here if it works

  5. #25
    " MAke sure the .net framework 3.5 is installed (enabled in the Windows features on Win 10.)
    Run the UCx00 automatic installer application, select MAch4 and select the UC100 if you using that.
    Make sure to plug in the UC100 to the computer's USB port. (You can also verify that the USB drivers were installed properly with checking the Windows device manager.)
    Run Mach4
    Enable the plugin in MAch4.
    Select the UC100 as motion control device in MAch4.
    Enjoy. "


    Unfortunately it didnt work!

  6. #26
    OK
    so sent a query in to Artsoft . Mach support supplied a remote connection link and while I was having my dinner the problem was resolved in my absence . Came back after dinner and a notepad message told me UC100 was now connecting.
    I will ask tomorrow if they can tell me what was wrong for the sake of others who may have similar probs .
    I will now embark on the configuration process, but already I have the tool post whizzing about at silly speeds . Probably need a bit of motor tuning but that will be tomorrow.

    Thanks to all that have tried to help . Will come back if I can get more info on what I might have done wrong.
    Meantime I will continue with configuration and motor tuning then maybe see if I can do spindle pulleys and threading.

    Watch this space

    John

  7. The Following 2 Users Say Thank You to John11668 For This Useful Post:


  8. #27
    So it seems I did not enable the plugin.

    Now I have to say that finding your way around Mach 4 is anything but intuitive so that is my excuse .
    This is not helped by the simple fact that the manual applies to the 2014 version, and version 2 of M4 which has only been around since early 2018 has not yet had an updated manual produced.
    So you try working through the old manual , and find the various configuration pages in the current version bear no resemblance at all.

    Now while the functionality looks good in M4 with a lot of (maybe too many) options on the front page, and once you find your way around it may indeed be superb but I am still wandering in the jungle , and the guy who made the signposts, does not seem to have ever worked with M3 so they seem to be in a language much of which is foreign to me .
    There is just too much on the front page . I cannot believe it would ever be used by the typical guy on a production machine

    Obviously I have spent a lot of time on the forums in the meantime and there seem to be precious few who have mastered it, and I get the impression that most have stepper spindles , and those who have VFD control, or like me a DC motor with pwm are even fewer so constructive advice seems to be in short supply.

    Doddy tells me that Linux CNC will involve a steep learning curve . I am wondering if Mach 4 might be just as steep.
    Added to the fact that (it seems) threading will not be supported with UC100 so I will not be much further forward .

    It seems that this device http://www.pmdx.com/PMDX-411 will cope with threading but is limited to 17 usable pins, so makes me wonder if I might be better saving myself a 100 on this and put it towards an ethernet device.

    Meantime , back to playing with the wizards available in Mach 3 .
    I have managed to string a few together to make some Knobs and tapers and stuff, but I guess it is going to be a while before I get to make stainless steel bolts to suit my mates old Ariel red Hunter

  9. #28
    Go linuxcnc John
    It works out of the tin
    And there is support on the forums for it
    Im no expert but have got my orac fully sorted on linuxcnc and to coin a phrase it just works
    Its been faultless

    The biggest hassle was getting things like a WiFi pendent and control panel buttons to work but I now have Hal and I in files that I will happily share with you so you are tweaking rather than writing from near nothing

    Paul


    Sent from my iPhone using Tapatalk

  10. #29
    Fwiw..
    My main use is lathe, and I am using mach3 mostly, and slowly migrating to mach4.

    Have more than 2000 hours of use on mach3 lathe.

    My 12x24 industrial lathe is a very deep refit, industrial quality (on version 4).
    32 mm ballscrews (z), 0.01 degree indexing on C axis, 0.2 micron theoretical resolution, scratch built saddle on hiwin 25 linear rails, 32 mm ballscrew on x.

    Now moving to linear rails on z, hiwin 25, to get sub-micron mechanical resolution (0.3 micron theoretical resolution) using ac servos of 750W, 220V.
    1:2 belt drive, HTD 8 mm / 30 mm, taperlock pulleys from bearingboys uk.
    This is the work of this week, about 40% done.

    2 toolchangers, 4 tool revolver and 7 tool servo turret at back (not yet mounted), about 60 kg in mass for the turret.
    Basic lathe was 350 kg originally, now around 500 kg.

    I am very happy with mach3, machx.
    Using a csmio-ip-s controller with lots of 24 V io.

    Afaik, the spindle speed display is not related to the pulleys.
    It just displays what the configured index signal tells the controller the speed is.
    The display =/= what the actual accurate spindle speed and position is.

    My spindle speed and position are accurate to about 0.04 mm on the circumference of a 200 mm disc, while cutting.
    The actual spindle speed is accurate to much better than 0.1 rpm, perhaps 0.00x rpm.

    It tracks to around 500 error counts, (when the spindle drive faults) but the error is never more than 10 counts in variation.
    Typically, the error is around 1-2 counts, of 1 : 3x10.000 = 2 counts per 30.000 counts/rev.

    In case of hitting a hard turning interrupted-cut edge the error count might be 10 counts for maybe 0.1 secs.
    The led on the servo drive hardly has time to flicker.

    The z and x axis drives fault faster than the lathe can break itself, in about 0.01 secs, as anything steel and cast iron can survive the minimal bend they get in that time, even when using upto 1000 kgf push force.
    The servos fault in about 0.01 secs, 0.02 secs, on hitting something or overloading.

    So the tools and toolholders and mounts bend before breaking, and the servos fault.
    Typically within about 1 mm or less, sometimes much less.
    X has about 1200 kgf push, z about 1800 kgf.

    Using a *good* hw controller like the csmio-ip-s is the key.
    It reads the servo encoders of 10.000 counts in real time for threading.
    And outputs upto 4 Mhz of perfectly accurate pulses.
    And has industrial 24 V io.
    Endless io.
    Unfortunately, it is quite expensive.

    But so are all other options, when adding in 4 Mhz speeds, encoder tracking, 6 axis, 120+ IOs, 24V IOs, etc etc.
    Differential drives.
    Analog inputs and outputs of high quality with *good* plugins with *good* support.

    The csmio-ip-s supports glass scales for extra accuracy.
    I intend to install them at some point.
    My goal is to make threads of sub-micron accuracy, industrially.
    I have spent 17 years and 150k on the journey.

    My many points are:
    1.Machx is quite upto the task of high end stuff.
    2.Better stuff is not quite free, and 500$ will not buy you all the hw you need for a controller.
    3.It is very very hard to actually do stuff really very well.
    -- For wood routers and basic 3d woodwork most-anything will work.
    4.Linuxcnc will also work very well for high end stuff.
    Nothing against linux, I used it professionally and industrially in my xxM IT shop very successfully in great scale.

    If your index signal is on the spindle, then the pulley should have nothing to do with it.
    Whatever pulley you have in use, you get a given speed, and the index signal should show that speed.
    No ?

    In My Experienced Opinion:
    No matter what, your index signal is likely flaky.
    At varying speeds, depending on pulleys and/or variable drives, the index signal is going to be fuzzy and not crisp on some or all speeds.
    Most likely all speeds.

    So the signal triggering is going to vary by some amount in ms partly related to the speed of the spindle, and not constant at all.
    Ideally, your index signal needs to indicate the exact angular position of the spindle, related to the exact angular position of the thread, to less than 0.02 mm error at the outer diameter of the workpiece.
    On a typical sub-20 mm D thread you are looking for an angular resolution of about 0.05 degrees, +/-, better than 0.1 degrees.
    Otherwise the sw will cut the thread undersize or oversize or wonky depending on where the sensor triggers.
    Where the sw is performing perfectly correctly - but it just gets wrong info in from the index sensor.
    The index signal wanders, because it is fuzzy, and not consistent.
    It is not crisp enough.
    Not repeatable enough.

    I tried 4-6 different sensors and 2-3 different hw solutions and bobs, until we worked on this with Sergey from centipede many years ago.
    Scanning at 500 MHz with special hw and sw, we proved conclusively that the index sensors are fuzzy and their triggers are not consistent.
    The lathe speed with a very heavy chuck aka high inertia was extremely constant, but the index sensors were triggering all over the place.
    This meant that the threading algorithm was chasing the sensor reading, and resulting in uneven threads, of varying reliability.
    At some speeds, D, depths, temperature and tools it might work well.
    Afternoon, in use, lathe runs at 550 rpm. 18 C.
    Morning, 8C, the lathe runs at 480 -510 RPM because everything is cold.
    One or the other might work well, sometimes, but would not be reliable.

    After he built a new crisp hw board the results improved 1000x.
    A cold lathe at 480 rpm in the morning would perfectly chase a thread made at 550 rpm the previous day, with less than 0.01 mm error.
    I used dull copper and a scratch pass to prove this.
    0.01 mm errors are perfectly visible.

    Today, my opinion is that only optical encoder indexes are accurate.
    But most cheap hw boards will not read optical encoder pulses on z, /z (differential), because they are so short in duration.
    Its possible to stretch the pulse with some electronics, I never tried it.
    Should work, I think.
    Likewise, encoders on belt drives should work perfectly fine, imo.

    After 5 years and 1000+ hours and 1000+ I just bought the industrial controller and the industrial servo drive and built an industrial-level belt drive for the spindle.

    HTH.
    ;)

  11. #30
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 23 Hours Ago Forum Superstar, has done so much to help others, they deserve a medal. Has been a member for 9-10 years. Has a total post count of 2,822. Received thanks 346 times, giving thanks to others 8 times.
    FFS. Do we really need to tolerate Hanermo's fantasy lathe ramblings again?
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Small Mach3 Problem
    By needleworks in forum General Discussion
    Replies: 8
    Last Post: 11-05-2020, 10:46 AM
  2. CONVERSION: Emco F1-p Mill Mach3 convention, Spindle motor problem
    By andre13442 in forum Conversion Build Logs
    Replies: 7
    Last Post: 14-01-2016, 12:14 PM
  3. Replies: 5
    Last Post: 29-09-2014, 02:42 PM
  4. Mach3 & V-Carve Problem
    By Ricardoco in forum Computer Software
    Replies: 2
    Last Post: 31-05-2013, 12:53 PM
  5. Mach3 small problem
    By dudz in forum Artsoft Mach (3 & 4)
    Replies: 7
    Last Post: 15-11-2012, 05:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •