. .
Page 1 of 2 12 LastLast
  1. #1
    Hi all, I purchased a Boxford 125 TCL (Mach3 conversion) a little while back with the intention of also buying a Milling machine which has also been converted to Mach3 so I could have a little home machining setup. When I got the 125 TCL home I plugged it all in and ensured everything was working as it should (X/Z axisí & spindle), and all was fine (I also have a YouTube video demonstrating it working from the seller), so I left it dormant for a little while until I found the free time to delve deeper

    So i recently decided itís time to start cutting some material and Iím a CNC machinist by trade so the programming side is no issue. So I fired the lathe up and homes the X & Z axis, however when I tried to command the spindle to rotate with a simple ďM03 S1000Ē command, nothing happened. Iím not sure if I was in the correct Mach3 profile at the time, but wether I was or not is irrelevant now as Iíve tampered with the settings so need to go back to basics. Iíve read all sorts for forums and scoured through a multitude of YouTube videos trying different values in ports and pins but so far Iíve had no success

    To be clear, I have no experience with the internal workings of these machines although I am somewhat familiar with basic electronics, and I am just getting to grips with Mach3. Along my research and peering inside the machine I kind of figured out the basics going off the control board and I understand how the pins correlate to the inputs within Ports and Pins, although there are 25 pins on the data cable and only 16 inputs on the board. Besides that my findings for the control board are as follows:

    1. (I think this feeds to the spindle relay but not 100%)
    2. X-axis +
    3. X-axis -
    4. (Empty)
    5. (Empty)
    6. Z-axis +
    7. Z-axis -
    8. (Small cable feeding into another board, which is labelled ďstepĒ)
    9. (Empty)
    10. Kill switch
    11. X-axis limit switch
    12. (Small cable feeding into another board, which is labelled ďoutĒ)
    13. (Empty)
    14. (Empty)
    15. (Empty)
    16. (I think this feeds to the spindle relay but not 100%)

    So, I am happy that the X and Z axisí are working correctly along with the X axis + limit switch and the kill switch, however I am stumped on the spindle. I assume that ports 1 and 16 are being used to drive the motor as they feed to a large relay which goes to the motor (with a couple of pieces of hardware in between) and port 8 is being used to tell the relay to kick in, but as I mentioned Iím simply a noob and itís 0 understanding of these machines

    I have attached a handful of pictures, some of the machine and some of the Ports and Pins pages so see if somebody can guide me into the right direction

    Many thanks, Repro!

    Click image for larger version. 

Name:	F7959DB5-A538-4AF8-96F1-E3DC8860C0C7.jpg 
Views:	116 
Size:	397.3 KB 
ID:	30428Click image for larger version. 

Name:	3DAEEACE-3EBD-41FE-A79C-8F6EA0F75209.jpg 
Views:	96 
Size:	343.4 KB 
ID:	30429Click image for larger version. 

Name:	9F6C6CAC-3001-4A89-B687-24AA34F728B7.jpg 
Views:	95 
Size:	347.5 KB 
ID:	30430Click image for larger version. 

Name:	image.jpg 
Views:	108 
Size:	320.5 KB 
ID:	30431Click image for larger version. 

Name:	image.jpg 
Views:	116 
Size:	276.8 KB 
ID:	30432Click image for larger version. 

Name:	image.jpg 
Views:	133 
Size:	455.5 KB 
ID:	30433
    Last edited by Reprobus; 15-09-2021 at 01:00 PM.

  2. #2
    Hi Reprobus . Thanks for detailed post .
    Certainly a lot different to mine . See http://www.mycncuk.com/threads/13959...TCL125+boxford Skim through and you will find pic of the guts of mine.
    Doyou know its history ?
    Certainly looks to be very much adapted from original Although original motor , choke and power supply transformer seem to be there . with a few added items of "bespoke" origin.
    My motor drive was a Lenze type and looks at first glance to have been replaced by the gemini contraption on the right . More details of that would be useful.

    Your BoB is a very old style compared to the sort we seem to see more often these days https://www.ebay.co.uk/itm/393334570...cAAOSw-7ZgpVSd
    There may be some info on the underside regarding the functions of the terminals on the near end of your board . but depending on where they are connected this may give us some clues .
    Just beware . I cant see any info to specify whether the Gemini controller is an "isolated " drive . If not there may be some high voltages waiting to bite you.

  3. #3
    Thanks for your reply, it is very much appreciated. I tried to put as much info in the post as possible to compensate for my lack of knowledge

    In terms of what parts are original and what are aftermarket, I have zero clue, so hopefully Iíll be able to learn more about my machine a my research goes on

    Yes I do believe my BoB is old as it has no USB input. Would you recommend me upgrading this?

    I also noticed that one of the white electrical boxes (shown in the pictures I posted earlier), the green LED is lit on one but not on the one next to it. Iím unsure if that could be part of my issue

    I see, so whatís the difference between an ďisolatedĒ drive and presumably a ďnon-isolatedĒ drive?

    Thanks, Repro
    Last edited by Reprobus; 15-09-2021 at 09:35 PM.

  4. #4
    Leaving isolated drive for now ( I suspect yours is isolated)
    You may be on the button WRT the white box which appears to be a 24v power supply.
    I am thinking that this would be needed for your spindle to be controlled by Mach 3 and your Bob.
    So test the DC output and report back. If output seems OK then follow it through to the Bob.

    I can see some queries with regard to some of the Mach 3 settings I see , but lets go one step at a time !

    As an aside I was advised to leave mach 3 and go to linux . Hard going but worthwhile ,
    but I would stick with M3 until you see all functions working.

  5. #5
    The 24v box isnít putting out any power for some reason, Iím unsure whether the DC converter is broke or whether a signal has to be received from Mach3 first before the box puts out the power. I shall investigate

    My new BoB has now arrived, so before removing the old one I labelled all of the wires to eliminate errors. The layout of the ports on the new BoB is rather different from my old one, but unfortunately I canít upload a picture.
    Between ports 2 and 3 (for example) on my old BoB there is a port labelled ďCOMĒ which I presume is ground. This isnít on my new board so I routed the wires around to another ground port on the side

    After fitting all of the wires to the new BoB I powered up the machine and tried to jog the X and Z axis but there was no movement at all, nor from the latheís kill switch. Iíll re-fit the old one for now and focus on getting the spindle turning
    Last edited by Reprobus; 15-09-2021 at 09:34 PM.

  6. #6
    So I refitted my old BoB and I can now jog the X and Z axisí again

    With this I decided to troubleshoot the 24v box and I have come to the conclusion that it is knackered. Iíve just ordered a replacement so Iíll hopefully have it fitted this time next week

    I will leave the old BoB installed as I know it works. Providing I can get my ports & pins/set up data sorted she should run
    Last edited by Reprobus; 15-09-2021 at 09:22 PM.

  7. #7
    Be interested to hear what the replacement does !
    AFAIK no signal is needed from Mach3 to cause the PSU to work . It should be on from switch-on.
    but without the supply to the board, the spindle relay will not cause the spindle to operate. Modern boards are happy with 12v but your old soldier BoB may need 24v.

  8. #8
    Thanks for your response

    So Iíve replaced the 24v supply, the board has power and the relays are kicking in when I tell the spindle to turn (Relay 1 with M03 and Relay 2 with M04). I count this as a success, however the spindle still isnít turningÖ

    The only pins which I couldnít work out on the BoB are pins 8 and 12. As mentioned in a previous post, pin 8 goes to another board where the terminal is called ďStepĒ. Could this be what Iím missing for Mach3 to monitor/control the spindle RPM? If so, where within ďPorts and PinsĒ do I put this value?

    Thanks, Repro

  9. #9
    So it sounds like your forward and reverse relays are now supplied .

    Next thing to check is your spindle DC driver which is board with the orange perspex cover ( GEC gemini) . Do you have any info on it ? I cant raise any online.

    Would also be useful if we could identify the functions of two other boards The small one adjacent to the 5V psu (I am wondering if it could be a PWM generator) and the one at the far left corner by the yellow terminal block which I think will be a simple relay board.

    Somehow these in combination have to supply your DC driver board .
    This is the wiring of the original Lenze board used on some TCLs

    Click image for larger version. 

Name:	Lenze  connections.PNG 
Views:	105 
Size:	50.6 KB 
ID:	30456

    And I am using a Sprint DC driver with connections as shown here

    Click image for larger version. 

Name:	Sprint drive.PNG 
Views:	88 
Size:	22.7 KB 
ID:	30455

    You should see common elements here and I am sure your GEC board will have the same functions.
    A run switch, and a 0-10v dc potentiometer .
    On Sprint they are 5-9 , and 1,2,3 respectively
    On Lenze they are 16-17 and 7,8,9
    If you can determine which they are on GEC you should be able to test the motor function separately by connecting a simple switch and a pot .
    With these you should be able run the spindle independently of computer connections and prove its functon. Just make sure you let the spindle stop before selecting reverse .
    If successful you can even run the spindle in this way while you sort out the outputs from the computer in Mach.

    We can then look at Mach settings to supply these from your computer.
    I have to say I then get a bit stuck with Mach settings as I did not get as far as running my machine properly before I migrated to Linux.
    Maybe someone with more Mach3 lathe experience will step in here to help .
    I will see if I can find the settings I was using at the time

    I did get it running in Mach 3 after a fashion but thread cutting in Mach3 was not a success.

  10. #10
    Thanks for your reply, I read it back a good few times on Sunday to try to break it down and understand how the GEC board works, but no unfortunately I have no info on this at present. Indeed my board does appear to have similar connections to your Sprint board although the layout is different.

    Iím up for trying the ďswitch & potĒ although I have no idea what a pot is, haha. I wonít be able to try this until next week however as my schedule for this week is pretty crammed

    In regards to the two other boards you asked about, the small one is a relay board. It feeds relays 1 and 2 for the motor direction. If the other board is a PWM generator that might explain what my next step is within Mach3 > Ports & Pins > Spindle Setup

    Also, Iíve just picked up an old Denford Starmill from a friend so thatíll be the next project once I get the TCL running :)

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MK4 MACH3 Motion Card Problem with output control ports. NEED HELP!
    By Mushtantuk in forum Motor Drivers & Controllers
    Replies: 0
    Last Post: 18-06-2017, 02:36 PM
  2. Mach 3 ports and pins problems,
    By chris w in forum Artsoft Mach (3 & 4)
    Replies: 24
    Last Post: 06-04-2017, 03:25 PM
  3. Mach3 ports and pin setup to match my control box
    By Sparky in forum Artsoft Mach (3 & 4)
    Replies: 17
    Last Post: 13-11-2014, 04:00 PM
  4. ports and pins for system4
    By Dan Brown in forum Motor Drivers & Controllers
    Replies: 2
    Last Post: 18-01-2010, 06:37 PM
  5. Ports and pins help ? mach 3
    By xchipx in forum Artsoft Mach (3 & 4)
    Replies: 0
    Last Post: 19-04-2009, 12:45 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts