. .
Page 1 of 2 12 LastLast
  1. #1
    Hi Fellow CNC Enthusiasts,

    I am in need of assistance.

    I am using UCCNC Software to communicate to a AXBB-E Ethernet Motion Controller / Breakout Board.

    My CNC Machine runs fine both motion and spindle, however, from time to time the machine stops and I get the following message:

    Communication error:
    The application lost the connection with the motion controller device. Check the connection. The application is closing now! Save Offsets?

    On exiting from this message the CNC software shuts down. Sometimes I can restart the software right away. Sometime I need to power off and on the AXBB-E to get the software to start again (as it will want to start in Demo Mode). In some cases I've had to reboot the computer before it would start again.

    The Controller and Software were loaded recently so should have latest versions. I connect the controller directly to my laptop ethernet port with a cross-over cable (CAT6). I set a static IP address with a submask of I can ping the AXBB-E without issue.

    My notebook is as follows:

    Toshiba Notebook running Windows 7 Home Premium with Service Pack 1, Intel Core5 2430M CPU @ 2.4 GHz, 6 GB RAM
    The Graphics card shows Intel HD Graphics Family

    I've tried the following (one at a time) but the issue did not resolve

    1. changed the cross over cable
    2. added a ferrite to the cable (to attenuate possible EM noise)
    3. de-energized the VFD and ran motion commands only
    4. played with the Ethernet port properties. Disabled Energy Efficient Mode and Enabled "Wake on Magic Packet"
    5. checked that DC power supply V0 is distinct from AC GRND.
    6. on loss of communication I checked the voltage on the AXBB-E and all is as expected at 24V and 5V.

    Any suggestions would be appreciated as I've consumed a lot of hours in trying to resolve this myself.

  2. #2
    ZASto's Avatar
    Lives in Belgrade, Serbia. Last Activity: 6 Hours Ago Has been a member for 3-4 years. Has a total post count of 48. Received thanks 1 times, giving thanks to others 1 times.
    So, it looks that you have a network controller in the note book going to sleep.
    I guess that you should find somewhere in the network controller properties option to disable powering off.

  3. #3
    When you say "network controller" what are you referring to? Is this the actual AXBB-E device?

    The loss of communication can occur while the machine is in motion so not sure why it would be going to sleep.

  4. #4
    I suspect it's a PC Ethernet card issue rather than the controller. We fit AXBB-E and UC300 controllers to all the machines we build and they are 100% rock-solid stable and never had one Ethernet issue which was down to the controller. Can you try another PC.?
    -use common sense, if you lack it, there is no software to help that.

    Email: [email protected]

    Web site: www.jazzcnc.co.uk

  5. #5
    Quote Originally Posted by JohnnyCimino View Post
    When you say "network controller" what are you referring to? Is this the actual AXBB-E device?

    The loss of communication can occur while the machine is in motion so not sure why it would be going to sleep.
    The network controller in your laptop. ... but it can also be the energy saving alternatives of the PC itself. I don't know what is that "wake on magic packet" means but if your network controller is not allowed to be switched off at all then you should not need any wakeup. It sounds very much like the others said, a PC problem, not the AXBB-E.

  6. #6
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 2 Days Ago Forum Superstar, has done so much to help others, they deserve a medal. Has been a member for 9-10 years. Has a total post count of 2,907. Received thanks 360 times, giving thanks to others 8 times.
    Quote Originally Posted by JohnnyCimino View Post
    I can ping the AXBB-E without issue.
    Just to clarify, can you still ping the AXBB-E after the problem happens?

    5. checked that DC power supply V0 is distinct from AC GRND.
    Which DC power supply?
    The control DC power 0V should be tied to GND to avoid floating voltages, although most control boxes will usually have some component that ties it to GND anyway.

    Regardless, ethernet itself is fully isolated, so voltage mismatches shouldn't directly affect it.

    Have you tried power cycling the AXBB-E, instead of the computer?

    As has been suggested, I'd try a different computer, as that will at least eliminate one possibility.
    If you've not got access to another computer, try creating a new power profile, with all power saving options turned off. On laptops, some power saving features can appear to do strange things.

    For reference, Wake on Magic Packet, is just Wake On LAN. Shouldn't make any difference to how the ethernet port functions with the computer on.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  7. #7
    Have a look at post #4 in the following thread which directs you to the event viewer in Windows. You might find something similar in the records.

    I thought I'd fixed it by changing the USB port my pendant was plugged into but then it happened again and I gave up trying to fix the problem on the laptop and reverted to using an old W7 desktop machine which has been rock solid ever since. You could also have a look at the UCCNC forum.

    An optimist says the glass is half full, a pessimist says the glass is half empty, an engineer says you're using the wrong sized glass.

  8. #8
    Hello Forum Members,

    Thank-you for all the feedback to date. I wanted to add one more piece of information that may help with resolving.

    I opened the UCxxx Utility (Version 1.8) and completed a scan. The Scan found the AXBB board (see attached picture). I highlighted the row and then "Test Connection" and got an error indicating the IP range or netmask setting is wrong. See attached picture for screen shot of erro.

    I will wait for feedback based on this new information before proceeding to the next step which is to take my notebook to the computer store to check and possibly replace the ethernet port and card (unfortunately I do not have a second computer that I can try).

    Yesterday I was able to ping successfully. Today for unknow reasons I cannot. The UCCNC Software is only coming up in Demo mode.Click image for larger version. 

Name:	UCXXX Error.jpg 
Views:	138 
Size:	70.4 KB 
ID:	30758

  9. #9
    Did you try to contact CNC Drive? Perhaps they know something we don't.

  10. #10
    The issue is now resolved and my connection with the AXBB-E is stable. Here is what I did to resolve the issue:

    1. I was sharing the 5V DC Power Supply with several devices. I installed a dedicated power supply that feeds just the AXBB-E board. I believe the AXBB-E is sensitive to any fluctuation in voltage.

    2. I updated the configuration as follows (please note that on my system I have the AXXBB-E board connected via a cross-over cable directly to my notebook's ethernet card): My ethernet port IP address was changed from a dynamically set IP to a static IP. This is exactly as per the manual. The static IP is with a mask of What I was confused about is that this is the IP address of the Ethernet Card (and not the AXBB-E Card). I then used the UCXX utility that comes with UCCNC to set the AXBB-E card IP to with the same submask This essentially establishes a local subnet consisting of the ethernet card and the AXXB-E card. After this revised configuration the "test connection" button on the UCXX utility is successful and CMD pings to both and are successful.

    Hope this helps other users. It consumed many hours of head scratching to resolve.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help needed to connect my VFD to the AXBB controller
    By CharlieRam in forum Spindles & Drive Motors
    Replies: 24
    Last Post: 23-09-2020, 12:10 PM
  2. Replies: 18
    Last Post: 31-01-2020, 11:58 PM
  3. Any USB/Ethernet controller suggestions?
    By jtar40 in forum Motor Drivers & Controllers
    Replies: 64
    Last Post: 15-05-2019, 07:58 PM
  4. USB/Ethernet controller for Mach3/4 advice
    By paulus.v in forum Control Hardware & Systems
    Replies: 17
    Last Post: 17-02-2015, 09:37 PM
  5. CNC controller with serial (RS232) communication
    By rnr107 in forum Motor Drivers & Controllers
    Replies: 15
    Last Post: 28-02-2012, 09:49 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts