. .

Thread: Homing

  1. #1
    Hi All
    I have my limit switches working but when i hit home on any axis nothing moves what have I missed

    Mike

  2. #2
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 7 Hours Ago Forum Superstar, has done so much to help others, they deserve a medal. Has been a member for 9-10 years. Has a total post count of 2,908. Received thanks 360 times, giving thanks to others 8 times.
    If you're using the same switches for limit and homing, you need to disable the limit function while homing.

    How you do that will depend on what controller/software you're using.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  3. #3
    What controller are you using? Mach3?

  4. #4
    Quote Originally Posted by JohnHaine View Post
    What controller are you using? Mach3?
    Hi I am using a Mach3 USB Interface Board and Mach 3 Sheen set 2010 to run it. I dont seem to have any power to any axis when press home. what have I missed?

    Mike
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20181228_145312__01-800.jpg 
Views:	7 
Size:	119.5 KB 
ID:	32189  

  5. #5
    I assume that you can jog so movement is working? The first thing is to check there is homing code behind each button. Which button are you clicking? On my "reference" copy of M3 (on laptop not connected to machine) this is the code behind "REF ALL HOME" on the run screen:

    DoButton( 24 )
    DoButton( 23 )
    DoButton( 22 )
    DoButton( 25 )

    DoOEMButton(133)
    DoOEMButton(134)
    DoOEMButton(135)

    I think those buttons are not linked to any code that causes the machine to move they just zero DROs. To see the code select "edit button script" from the operator menu - buttons with linked scripts will flash - click the one you want to look at.

  6. #6
    Click image for larger version. 

Name:	ScreenHunter 154.png 
Views:	13 
Size:	4.3 KB 
ID:	32190
    Hi is a screen shot of top tool bar. I dont get anything if I click on "edit button script"
    Mike

  7. #7
    Sorry yes all axis are working
    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mach 3 homing
    By johnboy48 in forum Artsoft Mach (3 & 4)
    Replies: 10
    Last Post: 25-10-2022, 05:54 PM
  2. About homing and switches...
    By JW1977 in forum General Electronics
    Replies: 39
    Last Post: 09-09-2019, 09:16 PM
  3. CNC first setup homing
    By Gary1329 in forum General Discussion
    Replies: 1
    Last Post: 30-07-2019, 11:40 PM
  4. Problem with homing
    By Andyman in forum Gantry/Router Machines & Building
    Replies: 4
    Last Post: 22-03-2016, 07:56 PM
  5. Homing Switches
    By m_c in forum General Electronics
    Replies: 3
    Last Post: 04-11-2010, 11:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •