. .
Page 1 of 3 123 LastLast
  1. #1
    Hi All

    This one has me stumpped!

    Last week my computer that I have been using to control my machine died on me,because it was a fairly low spec
    1Ghz processor 1gig of ram I decided not to spend anytime trying to repair it, but built a new one with some bits I had laying around. The new spec is Dual core 2.4Ghz 4 gig of ram 160 gig sata 2 hard drive complete clean install of windows XP with all latest updates and a clean install of Mach3.

    This is where problem begins, I loaded my original xml file, my machine did what ever I asked while jogging it around, so I loaded a simple engraving file and set it to work. Not long into the job I noticed that the engraving was getting lighter until eventually the tool was not touching the job, so I stopped the machine and homed all axis and sent it again, the Z was spot on at the start point but the same thing happened the tool height was changing as the job was running.

    I removed the tool and fitted my plunge guage and loaded some G code moving the Z axis up and down at full speed with varying heights from 90mm to 0.1mm and finished at Z zero the guage was bang on no sign of missing steps so I have come to the conclusion it must be something to do with the pulse train from the PC when all axis are moving.

    Has anyone else had this or can anyone come up with any ideas to what I can do to sort this damn problem out?



  2. your problem is that the step rate specified in the Mach 3 XML is related to the machine clock speed - not the value you entered on screen, so it is likely MACH3 is not sending wide enough pulses and so your driver is missing some step pulses under 3-axis load. Go back into the MACH3 setup, and change the pulse width setting to 5 or 6 and resave the XML... it might be worth checking the MACH3 kernel speed settings...

  3. #3
    Hi Irving thanks for the reply.

    The Kernel speed is set to 35KHz the same as before, I have tried changing the pulse width but only on the Z axis I will go and give it try on all axis and saving the XML.

    One more thing I have noticed is the Home LED's on the MACH diagnostics screen, when my home switches are made they are flashing randomly but the LED's on my breakout board are solid and the home switches work fine?

  4. #4
    Irving I have just tried your suggestions but no difference.

    I can feel my hand going in my pocket and bringing out a smooth stepper!

  5. Shouldnt be necessary Andy...

    Check the grounding of the parallel port. Whats your BOB & driver(s). The MACH3 home 'LEDs' should be solid, if they are flashing but the BOB is solid then this sounds like a grounding or isolation problem... and whats causing that one way is probably having a similar effect the other way...

  6. #6
    Go to Config > General Config and in the top right set the debounce to about 1,000.
    Try that and if necessary up the debounce further
    John S -

  7. but that wont address the stepping issue will it?

  8. #8

    The breakout board is a CNC4PC 11G and the drivers are Gecko's 212's

    I will check the earthing tomorrow and report back.



  9. #9
    Quote Originally Posted by irving2008 View Post
    but that wont address the stepping issue will it?
    No but the flashing homes could be noise.
    John S -

  10. How are you providing the +5v for the BOB?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Roundover finishing - what's causing this..?
    By Wal in forum Woodwork Discussion
    Replies: 4
    Last Post: 18-03-2014, 03:37 PM
  2. My computer desk
    By wilfy in forum Woodworking Project Showcase
    Replies: 27
    Last Post: 25-12-2012, 09:35 PM
  3. computer crash help!!
    By dinasblu in forum General Discussion
    Replies: 2
    Last Post: 11-07-2011, 12:37 PM
  4. FOR SALE: Computer and other Bits
    By Jimmybristol in forum Items For Sale
    Replies: 0
    Last Post: 30-05-2011, 02:13 PM
  5. Add a computer to your network
    By Lee Roberts in forum Computer Software
    Replies: 0
    Last Post: 19-11-2008, 01:15 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts