. .
Page 1 of 3 123 LastLast
  1. #1
    Hi all
    im new to this game and I'm converting a seig x2 plus. But having serious problems with a pci parallel port card as lpt 1 or 3 to run the machine, the trouble is it wont even do the most basic communication
    1) oem drivers set up and working
    2) Device manager shows a new mulitfunction adapter - the same as the card make, using resources at EEOOO-EEOO7 (in the properties tab)
    3) but the new pci parallel port in device manager oes not have the make perhaps just a generic?
    in the resources tab it shows --- i/oEE00 - EE07 not available.

    I dont seem to have any communication to the b o board in the machine. is there any way i can reallocate the resources?
    iv tried all options in the device manager, none work all give the same " not availiable" error
    I tried disabling the mulitfunctional adapter but as expected the parallel port dissapeared from device manager

    The computer has been completely "bombed" and returned to factory settings. I could put xp on the machine, but don't realy want to because other ap problems
    so is it the card or me? Do I get another which allows a resource allocation to be manually set rather than automatic as with this one, but then what do I set it to?
    ps im running vista home, and will one day be able to use mach 3.......

    Any suggestions?
    thanks Graham

  2. #2
    I'm guessing that you are trying to set up Mach3 to use this card? Looks like you are using the wrong address. Take a look at this and see if it helps find the correct address. Typically, if there's only one parallel port on the machine it will be at address 0x378 although this can vary.
    Last edited by Neale; 06-12-2015 at 03:34 PM.

  3. #3
    I have a feeling that from Vista onwards LPT addresses followed a wider convention. Have you looked in your computer bios to see if an onboard LPT is enabled? If so you might want to disable it and try re-installing the card. 0x378 may then become available for your PP card.
    First you could try setting Mach3 to EE000 or whatever value you have in the device properties. Mach3 uses LPT in a 'special' way.



  4. #4
    Ta guys
    no onboard lpt or anything in the bios
    problem is that the i/ o range at EE000-EE 007 is shown in the device manager (resources) is listed as unavailiable with a red no entry sign in the device manager. On trawling through the other devices this address is used by the Raedon graphics card
    so I need to reassign one or the other.
    the parallel card uses automatic set up and can't be altered , in the general tab it says it's working properlythe part to do any change is greyed out. Not keen on doing the graphics card, this is all a bit beyond me
    I appreciate that mach 3 is looking at ox378, but the parallel card has no resources and as such there is no possibility of any communication

    keep the suggestions comming. Thanks for your replies , I spent a lot on this setup and its complete junk at the moment!

  5. #5
    Just for a bit more background - what PCI adapter card are you using? I have one in my CNC PC that works fine and I'm happy to check settings if it's the same or very similar one.

  6. #6
    Hi neal
    its an approx standard 1port parallel PCI card
    interesting the multifunction adapter in device manager l( the same card lists the Eeoo - ee07 and ef00-ef07 as no conflicts.
    Driver is WinChipHead 1.52013.4

    id be interested in your settings and the card you have


  7. #7
    Quote Originally Posted by Cnc many View Post
    problem is that the i/ o range at EE000-EE 007 is shown in the device manager (resources) is listed as unavailiable with a red no entry sign in the device manager.
    The red flag on the device indicates that the driver is not properly installed. It could be that the driver is not compatible with Vista. Software for a lot of add on cards was not developed after XP so you could be struggling. My dedicated CNC machine uses XP without any unnecessary 'features' I have PP card installed as well as the onboard LPT. Both work OK.

    If you go into Device Manager and click on the PP you will get a window with General, Driver and Details tabs. Under details there is a Hardware Id in the list. If you select this you should get the hardware id, which you can copy and paste into a search engine. It might point to a manufacturers page with drivers to download.

    It is a slim chance, but it is the best I can offer. It worked for me with XP.



  8. #8
    I'm using one of these on an AMD A55M-E33 motherboard.

    Here are some screen shots of device manager entries, which may or may not be useful!

    Click image for larger version. 

Name:	pp1.jpg 
Views:	422 
Size:	203.4 KB 
ID:	16716Click image for larger version. 

Name:	pp2.jpg 
Views:	392 
Size:	175.4 KB 
ID:	16717Click image for larger version. 

Name:	pp3.jpg 
Views:	407 
Size:	196.8 KB 
ID:	16718Click image for larger version. 

Name:	pp4.jpg 
Views:	395 
Size:	185.9 KB 
ID:	16719Click image for larger version. 

Name:	pp5.jpg 
Views:	399 
Size:	186.3 KB 
ID:	16720

    I'm inclined to agree with Rob - most likely issue is the wrong driver. Are you happy that you have the right one for your system? Again, FYI, I'm using Win7 64-bit. Sometimes you might need the corresponding Vista version (32- or 64-bit) if there is nothing newer around and these seem to run OK on Win7.
    Last edited by Neale; 06-12-2015 at 10:52 PM.

  9. #9
    hi ta
    checked the driver update and it says im running the most up to date going to contact the cnc hardware provider and to see if they have any ideas

    cnc4you.co.uk very helpful in the past, not the cheapest, but you talk to the guy who designed the bob and driver, they do a lot of cnc machining and machine building. not the cheapest, but iv heard of a lot of bad press about stuff imported from China
    ill also talk to Novatech later looks a good card, but......
    also rip off uk
    had a reply from a guy in canada on another forum, he suggests a card obtainable in the us for $15 here its 94.00 rip off!

  10. #10
    If you look at the CPC Farnell site they have a PP card Probably about 15 delivered, but they do say will work on any windows system (!) Maybe they missed out 64 bit when they tested it. If you have a 64bit system, this could be the problem. Have a look at the catalogue page, they do show one for 64bit systems as well.

    http://cpc.farnell.com/dynamode/pci-parallel/pci-card-parallel-1-port/dp/CS23378?mckv=sZpMNHAt6_dc|pcrid|75925306337|kword| pci-parallel|match|p|plid|&CMP=KNC-GUK-CPC-GEN-SKU-DYNAMODE-CS23378

    Last edited by cropwell; 07-12-2015 at 03:08 PM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. usb - parallel
    By universally in forum Gantry/Router Machines & Building
    Replies: 4
    Last Post: 12-03-2015, 04:03 PM
  2. Mach3 ports and pin setup to match my control box
    By Sparky in forum Artsoft Mach (3 & 4)
    Replies: 17
    Last Post: 13-11-2014, 04:00 PM
  3. New Motherboards and LTP1 ports. (You might have one)
    By Mattbatt in forum General Electronics
    Replies: 0
    Last Post: 05-04-2013, 10:12 AM
  4. ports and pins for system4
    By Dan Brown in forum Motor Drivers & Controllers
    Replies: 2
    Last Post: 18-01-2010, 06:37 PM
  5. Ports and pins help ? mach 3
    By xchipx in forum Artsoft Mach (3 & 4)
    Replies: 0
    Last Post: 19-04-2009, 12:45 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts