. .
  1. #1
    Hi, I have got the machine axes connected tonight to the csmio and powered up to test all was good apart from y axis no movement so x,z and a good (x needs reversing changing the setting to low made no difference) that is now a small problem as I tried the CS labs mpg unit and its lumpy in the movements so I read on forum that the mpg sets up its own settings when installed and you do not need to enable MPG#1 but when I installed the plugin I set it to enable, so
    i put it back to "not enabled" and all my settings for the machine have gone even the default IP address!!
    i set channels for motors and try to save but get " wrong value in axis encoder PPR value" message I have guessed at a few numbers but no luck have I completely wiped this motion controller of life??
    or is there a download that can restore basic info as the info I had wasn't far from default?
    thanks for any help,

  2. #2
    Chris you can't hurt the controller at all thru software changes other than when updating firmware and even then it would be simple reload.

    So what I think may have happened is you've maybe damaged the Mach3 Xml file or Cslabs plug-in. But to be honest I'm struggling to fully under stand what you did so can you be more clear.!

    Worst case scenario is that you'll need to re-install Mach3 and all the Cslabs plug-in's and re-enter your settings.
    The V2 MPG Encoder doesn't need any setting up it's all done for you, just make sure you terminate the Canbus with the provided terminator.

    But given the problems you seem to be having can I make a suggestion that you slow down with adding things like MPG and just get a sound basic working machine. Then start adding extra's like MPG because sounds to me like Your trying to run before you can walk.!!

    Why your having these problems I don't know because normaly provided you read the manual and understand the different way they use pin / Channel/enable setup compared to mach default way then these controllers just work and don't give any troubles. If there are any issues it's always just a simple setting that needs changing.

    To reverse an Axis goto Config / Homing & Limits and use the Reverse option.

    Give me clearer details on what you did and I'll try to make sense of it for you.!

  3. #3
    CS labs offer great support, so have you tried to contact them? it can take a few days for them to get back to you, but i have found that i have always got a good reply and fixed any issue i have had.

  4. #4
    the reason I added the MPG at an early stage is so I could have an ESTOP that I could take with me round the back of the machine,
    once the x axis had been proved to work a few nights ago, I then made a list of the terminals on the csmio to be used on the remaining axes y,z and a, I also colour coded them for the cat 6 wire I was using showing which terminals on the EM806 drives and double checked it, I was going to run a piece of cat 6 per drive as when I asked CSLABS why the MPG could be not I nice movement they told me it can only be noise, but I read the differential input manual and it shows its ok to use all 4 cores of cable to feed 2 drives as long as the ground at the csmio end terminated at 13,
    so I set it up this way after checking my drawings and terminal numbers again.
    powered up the machine and things ok checked the x axis first and fine apart from reverse, checked the channels on the plugin config for the remaining axes and they were good so I moved the z through the mach screen MPG and nice, same for the A axis, nice, no y response either direction. so I check things again and cannot find a connection problem y axis holding torque is good, the voltages from the drive pins when jogging is the same as the good axes, so I move each axis slowly with hand held MPG and notchy or lumpy in movement I don't know the best word for it, and still no y but I expected that.
    I look back at the forum and there is mention about no user setup required other than plugging it in correctly, I looked at the MPG setting and it was enabled so I disabled it and instantly lost all the values, that's exactly as it happened, I spent 15 mins trying to input but couldn't remember what the settings were as I had not altered most of them so no recollection of what the initial figures were,
    I have kept things tidy and written down every stage notes and not altered more than 1 thing at a time before testing it, its very time consuming but at least its traceable, but I never backed up the settings but be sure I will the instant that its back in a good state,

  5. #5
    Well I suggest you update the Firmware on the Cslabs unit to latest Firmware just to be sure. Then Re-install Mach3 and Cslabs Plug-ins.
    Re-enter all your settings.

    If you still have axis that don't move then I suggest you swap the non working axis drives with the ones that do work just to eliminate you don't have faulty drive/s.

    If not faulty drives and your 100% sure the connections correct and sound then send the IP-S unit back to Cslabs because you either have faulty unit or it's broken by something you did wrong?. In which case you won't know if the troubles you are having are because of this or down to you not setting correctly.

    It's very unusual to have these kinds of trouble with Cslabs stuff if the pins are connected correctly and understand the difference in way it works compared to mach3 normal way of working.
    Last edited by JAZZCNC; 08-01-2016 at 01:56 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dip Switch settings on the M542 stepper motor drivers
    By manofgresley in forum Motor Drivers & Controllers
    Replies: 13
    Last Post: 04-01-2021, 09:10 PM
  2. Saving machine settings between sessions
    By Neale in forum Machine Control Software
    Replies: 19
    Last Post: 07-05-2014, 08:17 PM
  3. Pulse rate or dip switch settings
    By Jopo in forum Stepper & Servo Motors
    Replies: 0
    Last Post: 29-04-2013, 08:08 AM
  4. Help with settings!
    By Tenson in forum General Discussion
    Replies: 26
    Last Post: 30-09-2012, 11:26 PM
  5. Calculating torque settings for bolts.
    By swarf-boy in forum Machine Discussion
    Replies: 2
    Last Post: 22-12-2010, 12:18 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts